8

I have installed xrdp on my Raspberry Pi (which is connected to my TV) and a program called CoRD on my Mac that lets me connect to the RPi remotely and I am able to see the RPi desktop without any issue.

However, the TV screen doesn't show what I am doing. What I mean is that I can create files, change settings, etc (and all that works) but if I open a window on the desktop that CoRD shows on my Mac, that window is not shown on the TV, it just shows the desktop like if I had just logged in. If I create a text file and save it to the desktop, it will show there (the icon will appear when I save the file), but if I open that file the editor window will just show on CoRD and not on the TV.

Is this just how the remote desktop works or is there a way to duplicate what I see in CoRD on the TV display?

6

If you're using vino for the VNC portion of xrdp (rather than vnc4server), you could follow these instructions to enable session sharing:

  • Log in to your Pi and install the Vino Package

    $ sudo apt-get install vino
    
  • Next Run X11

    $ startx
    
  • Once that is done you can run the vino-preferences from the terminal.

    $ vino-preferences
    
  • Configure it like you want it to work, if you want to be able to controll the remote Raspberry Pi computer without remote confirmation you have to check booth "Allow" boxes on top, uncheck the third "confirm" box and as a good recommendation check the 4 box about "Require user password" and enter a password you'll remember. The rest isn't that important so just click "Close" after that. Now Raspbian doesn't autostart vino, so we have to fix that, make a script in the /etc/sudoers.d folder.

    $ sudo leafpad /etc/sudoers.d/vsrv.sh &
    
  • put the following in that file.

    #! /bin/bash
    /usr/lib/vino/vino-server
    
  • Set the file to Execute

    $ chmod +x vsrv.sh
    
  • Then this file has to autorun when we start X11, on Raspbian this can be done by editing the /etc/xdg/lxsession/LXDE/autostart file:

    $ sudo leafpad /etc/xdg/lxsession/LXDE/autostart &
    
  • Just add this line at the end of the file:

    @/etc/sudoers.d/vsrv.sh
    
  • Reboot the Raspberry Pi

If you're not using vino with xrdp, you can follow these instructions:

  • Install xrdp and vino

    sudo apt-get update && sudo apt-get install xrdp vino
    
  • Configure vino so that you can remotely connect to the existing session

    Type vino-preferences from the terminal, check "Allow other users to view your desktop," "Allow other users to control your desktop," and configure the "Security" settings as you like (you will probably want to uncheck "confirm each access to this machine" and check "require the user to enter this password").

  • Configure xrdp to access vino

    Edit /etc/xrdp/xrdp.ini, adding in the text below. Alter the name to whatever you fancy. Also, make sure that [xrdp1] uses a number that doesn't conflict with an existing configuration.

    # set empty username because VNC auth 
    # doesn't actually use username, so no
    # point in asking the user for one.
    
    [xrdp1]
    name=Active Local Login
    lib=libvnc.so
    username=
    password=ask
    ip=127.0.0.1
    port=5900
    
  • Always try to remember that these links may disappear, and any more useful information that you can provide from the referenced pages, would be ideal. – kolin May 16 '13 at 11:44
  • @kolin Good point, I've updated my reply to have the instructions inline. – omgmog May 16 '13 at 12:16
  • path of the file changed for /etc/xdg/lxsession/LXDE/autostart to /etc/xdg/lxsession/LXDE-pe/autostart – Borik Mar 26 '15 at 14:25
2

In general this is how Linux like systems behave, each login to a VNC, SSH, RDP and actual terminal are distinct from each other, like many users logged in remotely to the same server.

I have come across x11vnc on my travels, which is meant to allow you to connect to a pre-existing X11 session (such as the real screen), but I have not tried it myself. You can see the page here, but it may be a bit fidly to set-up

1

I answered same question before: Raspberry pi remote access active session

You need to install x11vnc daemon on the linux distro with runs on Pi. Then run that command;

x11vnc -display :0 -usepw -noxdamage -ncache 10 -ncache_cr -listen IP_of_pi -allow allowed_ip_address

After ran the command, connect to pi with any VNC client.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.