4

I followed the instructions found on https://www.databinding.net/2017/09/09/net-core-2-0-auf-dem-raspberry-pi/ sorry it's in german but the install part is:

curl -sSL -o dotnet.tar.gz https://dotnetcli.blob.core.windows.net/dotnet/Runtime/release/2.0.0/dotnet-runtime-latest-linux-arm.tar.gz
sudo mkdir -p /opt/dotnet && sudo tar zxf dotnet.tar.gz -C /opt/dotnet
sudo ln -s /opt/dotnet/dotnet /usr/local/bin

I use a Raspberry Pi 2 Version 1.2 and tried the latest official stretch lite

Linux raspberrypi 4.9.41+ #1023 Tue Aug 8 15:47:12 BST 2017 armv6l GNU/Linux

and jessie lite

Linux raspberrypi 4.9.35+ #1014 Fri Jun 30 14:34:49 BST 2017 armv6l GNU/Linux

But I had no luck.

dotnet --version

allways terminates with segmentation fault.

Has anyone a running dotnet core 2.0 on a Raspi? Is it running on stretch or jessie (debian 8 or 9)?

4
1

@Aurora0001 gave the hint! I failed to validate the Raspi version. After putting the sd-card into a Raspi 3, the dotnet core 2.0 is running.

Linux jessie_lite_pi 4.9.35-v7+ #1014 SMP Fri Jun 30 14:47:43 BST 2017 armv7l GNU/Linux

and the dotnet command:

$ dotnet --info

Microsoft .NET Core Shared Framework Host

  Version  : 2.0.4-servicing-25824-03
  Build    : 901f257100c6f5e1833c83f9f91beb1f63be1ed2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.