0

I installed OMXPlayer which plays well but sometimes the screen size is well beyond the default. Since controls are off screen when this occurs you can only reboot to solve the problem.

1

OK, first of all: There is no need to reboot - you can just kill omxplayer's process (pkill omxplayer or kill xxxx, where xxxx is the PID - sometimes you may have to use kill -9 xxxx).
In order to issue the kill command, you can either ssh into your Pi from another box, or just open a terminal and type, in the blind, if the player obscures it, or even hit an ALT-F3 to use another tty (obviously, if you have the patience, you can even just wait for whatever is playing to just finish).

But you have other options - better ones, too:

1) You can use omxplayer's shortcuts to advance the playing to its end, or just plain stop it. From man omxplayer: "q exit omxplayer"

2) You can set the size of the playing window in advance, invoking omxplayer (again from man omxplayer) with parameters like --win 'x1 y1 x2 y2' or --win x1,y1,x2,y2
e.g omxplayer --win 0,0,500,400 myfile.avi - will play myfile.avi in a window starting at top left and a size 500x400

In general, man is your ally. Don't hesitate to use it...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.