2

I have had my Raspberry Pi for a few years now and today I went to do a fresh reinstall of Raspbian. I downloaded v2.4.4 of NOOBs and used that to install Raspbian. Everything installs nicely except now I am not able to connect to or even see any WiFi networks. In previous installs I just plugged in the dongle and it was able to search, but when I do it on this fresh install the following happens (I am using the GUI version of Raspbian):

  • Light on the USB does start blinking. Will eventually stop after a few minutes.
  • If I hover over the WiFi icon on the task bar it says:
    • eth0 Link is down
    • wlan0 Not associated
  • If I click on the WiFi icon it will say "No wireless interfaces found"

From the Googling that I've done, these are some of the commands I have done to try and diagnose the problem:

lsusb
> Bus 001 Device 008: ID 0bda:8179 Realtek Semiconductor Corp. RTL8188EUS 802.11n Wireless Network Adaptor
> ... other devices

The command ifconfig shows 3 sections, one each for eth0, lo, and wlan0. All the values (e.g. RX packets) show as 0. I am having to manually type out the results so haven't included them here as not sure if it's important.

The command iwconfig shows no wireless extension for the eth0 and lo entries, but for wlan0 it has more details. I can provide a photo of this if needed.

I'm at a loss really of what to do, as previously the WiFi has worked straight away. My Googling brings up results where people are not able to connect to a specific WiFi network, but I'm not able to view any and so I'm not sure if those results are relevant.

Thanks for any help.

  • See the settings in the answer to raspberrypi.stackexchange.com/questions/37920/… and also I had a similar problem on my Raspberry Pi 3 with built in WiFi due to someone had changed the /etc/network/interfaces by adding an ifacd after the auto lo directive. I commented the two added lines out and rebooted and WiFi then worked fine. – Richard Chambers Nov 1 '17 at 20:02
  • Thanks for replying. I have checked what my version of the file contains and it was completely empty (only the commented section and the include). I copied in the settings from that post and restarted but I still have the same issue unfortunately. – Peepy Nov 1 '17 at 20:47
  • When you use NOOBS, were you able to enable the WiFi and choose your access point? You mention a dongle. What is the actual hardware version of Raspberry Pi? And does your /etc/network/interfaces file end with the auto lo or do you have the additional iface directives from the posting? Mine does not have anything after the auto lo. And check the /etc/wpa_supplicant/wpa_supplicant.conf file as well. – Richard Chambers Nov 1 '17 at 21:04
  • Hi, I haven't had a chance to try yet and won't for the next few days. When I try it out I will let you know. Thanks again for your help – Peepy Nov 2 '17 at 9:42
  • Have you tried it now? – Ingo Dec 27 '19 at 19:41
0

Method 1: Default Wifi Setting

Press Ctrl+Alt+T and type

sudo nano /etc/network/interfaces  

Edit the Interface file

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

Save the file. And type this command in terminal

sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

Edit the wpa_supplicant.conf file.

country=IN
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1 
network={
        scan_ssid=1
        ssid="Your Hidden SSID"
        psk="Your SSID's Password"
        }

Please enter your Hidden SSID and Your Wifi password in scan_ssid and ssid. Make sure your raspberry pi country location should be me mapped mention country location.

Reboot the system.

Expected Output:

It will connect to hidden ssid

Method 2: Your Connecting to University or Organization Wifi

Press Ctrl+Alt+T and type

sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

Add the following:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=IN
network={
        ssid="XXXXXXXX"
        priority=1
        proto=RSN
        key_mgmt=WPA-EAP
        pairwise=CCMP
        auth_alg=OPEN
        eap=PEAP
        identity="18XXXXXXXX3"
        password=hash:d7XXXXXXXXXXXxXXXxce
        phase1="peaplabel=0"
        phase2="auth=MSCHAPV2"
}

Save the file and exit the wpa_supplicant.conf. Your need to give your hidden wifi name in place of ssid, user ID in place of identity and Password need to converted into hash code format.

Use this command in terminal to convert your password into hash code format.

echo -n 'YOUR_REAL_PASSWORD' | iconv -t utf16le | openssl md4 > hash.txt

Next Do the following:

  1. sudo nano hash.txt
  2. Insert hash: in place of (stdin)=
  3. Copy the entire text and exit
  4. Next modify the password in wpa_supplicant.conf file and exit

Reboot the system.

Expected Output:

It will connect to hidden ssid

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.