1

My Raspberry Pi Camera Module v1.3 is not working. I have tried taking a photo, and here is the error:

pi@raspberrypi:~ $ raspistill -o image.jpg
mmal: No data received from sensor. Check all connections, including the Sunny one on the camera board

So I used this command:

$ vcgencmd get_camera

output: supported=1 detected=1

So the red light comes on on the camera but doesn't take a picture. Tried rebooting to no success. Definitely not static discharge as the RPi still detects it. What could be the problem?

  • I'm afraid this usually means a hardware error. Either the ribbon cable, as noted by the answers below, the "SUNNY" cable on the camera board itself (while the camera is disconnected, prise this up with a fingernail and reseat it to be sure it's properly connected), or the camera module itself is dead (the module is static sensitive). – Dave Jones Nov 3 '17 at 11:45
  • will probably have to get another one, wonder why cant they cant make more resiustant to static charge. – Darkest N2O Nov 3 '17 at 11:48
  • My guess is that it could be sold encased, but that would add to the cost and make certain use-cases more difficult (hardware hacking, re-seating the module in certain enclosures, etc), and the foundation's usually very reticent to increase the price of things unless absolutely necessary (e.g. the Zero W). That said, even a simple thing like this would be helpful in keeping the board away from things – Dave Jones Nov 3 '17 at 11:57
  • that case dosen't protect the whole camera, so if you forgot to discharge yourself while you wanted to remove the camera you could still damage it. anyway thanks for your help :) – Darkest N2O Nov 3 '17 at 12:00
  • Yeah, it's about the most minimal case I've seen, but even it helps in reducing accidental camera deaths (e.g. dropping an active camera module onto the 5V pins). It's not ideal, and it's not the best, but it is cheap and does help (at least I've not seen any dead modules at various hack events since we've started using them, while dead modules were an occasional occurrence prior to that). One advantage of the design is that right angle is easily stuck onto ad-hoc cardboard robots (a frequent feature at such events :) – Dave Jones Nov 3 '17 at 12:09
1

I had the same problem lately. In my case the FFC ribbon cable was damaged. But as I tried to acquire an image, the red LED went on and stayed on forever. A new cable resolved the issue for me.

  • my light stays on till i shut the terminal or program. Also how did you test to see your ribbon was not working? cause mine looks ok but you never know – Darkest N2O Nov 2 '17 at 16:49
  • In one case there was a visible break in one part. The other time there was a short circuit between two pins sitting next to eachother. I verified it with a multimeter. The latter case was a faulty cable from the production. (cheap cable from china) – kwasmich Nov 2 '17 at 17:06
  • no visible breaks in mine, flat and straight. – Darkest N2O Nov 2 '17 at 17:52
1

Triple check your CSI connection.
It may seems trivial, but one can easily loose hours not doing it ! enter image description here enter image description here

Edit : as your camera is already recognized by the system, what we are looking for is a ribbon not tightened, or not perfectly parrallel with the plug.

  • thanks anyway but since i dont need this... its probably something witht the lens itself – Darkest N2O Nov 2 '17 at 16:47
0

I had the same problem, as indicated in the response with photos, be sure to check which CSI connection you are using on the Pi. Make sure you have it connected in the slot between the HDMI and the audio jack. I had mine in the one along the edge and was getting the errors indicated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.