1

I want know how to make a shortcut for rdesktop, the remote desktop client?

I installed it with this command:

sudo apt-get install rdesktop

I searched in the path /usr/share/applications/ but I see any resktop.desktop

Can you help to do that?

0

Create a new text file called rdesktop.desktop in the /home/pi/Desktop/ directory, e.g. /home/pi/Desktop/rdesktop.desktop

It should contain the following:

[Desktop Entry]
Name=rdesktop
Comment=RDesktop Shortcut
Icon=/path/to/a/icon/for/the/rdesktop/shortcut
Exec=/usr/share/applications/rdesktop
Type=Application
Encoding=UTF-8
Terminal=false
Categories=None;

Explination:

  • Name – The name you want displayed

  • Comment – Your comment

  • Icon – A file to use for the icon. Your own or have a look in the /usr/share/pixmaps/ directory for something suitable.

  • Exec – The executable (can include sudo if your executable uses the IO). Can be the name of an executable program, or more complex, e.g. Exec=lxterminal –command "less /root/README.TXT"

Requested Update:

for other keyboard letters (eg. è,é,etc...), get a virtual (onscreen) keyboard: First thing to do:

  • Open terminal

Second you will need to update your repositories:

  • sudo apt-get update

An upgrade to the whole system isn't needed but it is recommended:

  • sudo apt-get upgrade

Now we can install the virtual keyboard (matchbox):

  • sudo apt-get install matchbox-keyboard

Rebooting is recommended:

  • sudo reboot

Now you can access the keyboard:

MENU >> ACCESSORIES >> KEYBOARD

Access the keyboard
(source: modmypi.com)

If the keyboard isn't visible in the menu you can enable it by going to:

MENU >> PREFERENCES >> Main Menu Editor

There you will be able to enable the keyboard.

If everything has gone perfectly you will now have an onscreen keyboard.

Onscreen keyboard
(source: modmypi.com)

  • This is work fine. But I have some problem with the string who have accent like (è, é) the keyboard isn't at the good language. How can I fix that. I use a belgium keyboard. – lordaker Nov 3 '17 at 13:06
  • I dont understand what you mean – User98764431 Nov 3 '17 at 13:29
  • With rdesktop the keyboard (french belgium) don't work. The character like é or à or again è, don't work. I have this : é => e, è => e and à => a. How can I fix that and make the prominents characters work ? (It's when I connected to the Windows Server 2008 R2) – lordaker Nov 3 '17 at 15:04
  • see my edited answer – User98764431 Nov 3 '17 at 15:35
  • your welcome! – User98764431 Nov 3 '17 at 17:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.