2

I have just bought Pi, and I have no monitor to plug into it, so I thought I would do the DHCP trick. I installed the latest Raspbian wheezy (2013-02-09) on the SD and connected the ethernet cable into the router. But when I plug the power cable in, the light on the router does not go on, and the pi doesn't show up in the address list. What could have I done wrong?

  • When you power it up, does the activity LED flicker for a while, implying that it's booting up? I don't think mine connected to the network automatically, but I'm not sure. – Ian Howson May 17 '13 at 7:24
  • @IanHowson it's not activity, it's sd card access, i don't know why they marked it this very confusing way – lenik May 17 '13 at 8:46
  • Silly point, but do you know that Ethernet cable works? You imply that the light on the router does not show that there is any activity between pi and router, this to me would either say faulty cable, or corrupt Raspbian write to SD card – kolin May 17 '13 at 9:55
1

the latest raspbian does DHCP just fine, on the other hand, you might have missed something when creating your SD card. i'd recommend to get any cheap HDMI cable to connect your raspberry to any tv (ask your friends?) and see if it actually boots up.

also, the raspberry has 4 LED lights next to the USB connector, red one is power and the green one next to the read means "sd card access", it's supposed to blink from time to time during the boot. if it does not -- again, check your SD card.

  • thanks for the answer. yes when i plug everything in, only the power led gets lit. the sd card access led remains off. i'll start with that! – d--b May 17 '13 at 11:00
1

When you plug in your ethernet cable and the Yellow and Green LED lights next to the cable fail to light as expected, here's something to check first:

Log in to your modem and look at the port configuration settings. On my modem, this is found under advanced settings.

Ports can be configured to automatically sense the type of ethernet connection. In my case, the ports I was trying to use were set to 1000 Full Duplex. The Raspberry pi 3 can only do 100 Full Duplex, so the modem never set up an actual physical link on the port for the pi. Further, the Link Active and Link Activity lights never came on on either end of the connection.

I changed the setting to auto and rebooted the pi. The Link Active and Link Activity lights immediately started working and the PI had the internet.

-1

I had the same problem, my red Pwr light would come on but nothing else. Turned out to be that my SD card was somehow corrupted. I formatted a fresh one and everything worked fine again, all my lights are back.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.