1

I have tried to install the gdebi core in the termial but this comes up: T

he following packages have unmet dependencies:
 gdebi-core : Depends: python3-debian but it is not going to be installed
 skypeforlinux:amd64 : Depends: libasound2:amd64 (>= 1.0.16) but it is not installable
                       Depends: libatk1.0-0:amd64 (>= 1.12.4) but it is not installable
                       Depends: libc6:amd64 (>= 2.17) but it is not installable
                       Depends: libcairo2:amd64 (>= 1.2.4) but it is not installable
                       Depends: libcups2:amd64 (>= 1.4.0) but it is not installable
                       Depends: libexpat1:amd64 (>= 2.0.1) but it is not installable
                       Depends: libfreetype6:amd64 (>= 2.4.2) but it is not installable
                       Depends: libgcc1:amd64 (>= 1:4.1.1) but it is not installable
                       Depends: libgconf-2-4:amd64 (>= 3.2.5) but it is not installable
                       Depends: libgdk-pixbuf2.0-0:amd64 (>= 2.22.0) but it is not installable
                       Depends: libglib2.0-0:amd64 (>= 2.31.8) but it is not installable
                       Depends: libgtk2.0-0:amd64 (>= 2.24.0) but it is not installable
                       Depends: libnspr4:amd64 (>= 2:4.9-2~) but it is not installable
                       Depends: libnss3:amd64 (>= 2:3.13.4-2~) but it is not installable
                       Depends: libpango-1.0-0:amd64 (>= 1.14.0) but it is not installable
                       Depends: libpangocairo-1.0-0:amd64 (>= 1.14.0) but it is not installable
                       Depends: libsecret-1-0:amd64 (>= 0.7) but it is not installable
                       Depends: libv4l-0:amd64 (>= 0.5.0) but it is not installable
                       Depends: libx11-6:amd64 (>= 2:1.4.99.1) but it is not installable
                       Depends: libx11-xcb1:amd64 but it is not installable
                       Depends: libxcb1:amd64 (>= 1.6) but it is not installable
                       Depends: libxcomposite1:amd64 (>= 1:0.3-1) but it is not installable
                       Depends: libxcursor1:amd64 (> 1.1.2) but it is not installable
                       Depends: libxdamage1:amd64 (>= 1:1.1) but it is not installable
                       Depends: libxext6:amd64 but it is not installable
                       Depends: libxfixes3:amd64 but it is not installable
                       Depends: libxi6:amd64 (>= 2:1.2.99.4) but it is not installable
                       Depends: libxrandr2:amd64 (>= 2:1.2.99.3) but it is not installable
                       Depends: libxrender1:amd64 but it is not installable
                       Depends: libxss1:amd64 but it is not installable
                       Depends: libxtst6:amd64 but it is not installable
                       Depends: apt-transport-https:amd64 but it is not installable
                       Depends: libfontconfig1:amd64 (>= 2.11.0) but it is not installable
                       Depends: libdbus-1-3:amd64 (>= 1.6.18) but it is not installable
                       Depends: libstdc++6:amd64 (>= 4.8.1) but it is not installable
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Before I was trying to install skype but people said that I installed the wrong skype because I didn't have an AMD CPU.

Any help will be much appreciated.

  • 1
    Sounds like you want to install it, not just extract it. I'm sure Googling "how to install a deb file" will give you a million hits. Naturally the deb file needs to be for the Pi. – Mark Smith Nov 5 '17 at 11:34
  • I have edited the question. – DarthFigo30 Nov 5 '17 at 12:14
2

Unfortuantely you can't run an executable for amd64 on a Raspberry Pi. The various errors shown by your dpki -i skypeforlinux-64.deb coummand tell us you're trying to install the PC (amd64) version of the skype client. This will not work on a Raspberry Pi, because it is a different architecture.

If you've got an .deb for the Raspberry Pi, here is how to install it:

dpgk -i does not install dependencies automatically. You can either look at the output and install packages by hand (libasound2,libatk1.0-0, ...).

There is a tool named gdebi that can install a .deb with it's dependencies, but it must be installed first : sudo apt-get install gdebi-core.

Then you can run sudo gdebi toto.deb to install toto.deb.

  • I have updated my question. – DarthFigo30 Nov 5 '17 at 22:02
0

A .deb file is actually an .ar file with a pair of compressed .tar files inside.

ar -x whatever.deb

You may want to do this in a dedicated directory as the contents do not create one.

The .tar files may be a mix of .xz or .gz encrypted -- or, I suppose, anyone of a number of formats supported by tar (see "Compression Options" in man tar). They will be named control and data. The former again does not unfold tidily into it's own directory, the latter will create a hierarchy mirroring parts of a normal root filesystem.

tar -zxf control.tar.gz
tar -Jxf data.tar.xz 

The hierarchy will contain files that the .deb installs, in the location it would install them. The control files are a set of scripts used before and after installing, etc.

However, as pim points out, inspecting the file won't make it magically work if the binaries use the wrong ISA.

  • I updated the question. – DarthFigo30 Nov 5 '17 at 22:03
  • Oh I fixed it with sudo apt-get install -f – DarthFigo30 Nov 5 '17 at 22:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.