1

I am using Raspberry Pi 1 B+. Unfortunately, the new Raspberries that I bought recently (2017) don't boot anymore with my custom-made image. Only my Raspberries 1 B+ from 2014 accept to boot, so I guess something has changed despite being the exact same model.

So I've tried running updates on my image. If I run a full apt-get update / apt-get upgrade, it breaks completely and won't boot anymore on either Raspberries.

When I hold specific packages, I have managed to make a clean update. My image boots on both Raspberries, and everything works... except the ppp/pptp-linux packages.

I've tried both updating and not updating these packages, but it just does not work, which means my Raspberries can't connect to my VPN server anymore. I have also tried to hold/update all of their dependencies, to no avail.

Kernel before update : Current Kernel

Kernel after update : Post-Update Kernel

I have made a packet capture. 192.168.1.19 is my client (raspberry) and .37 is the server. It seems to be the server not responding anymore to the Outgoing-Call-Request ? There should be an Outgoing-Call-Reply. It happens correctly before the updates, though.

Packet Capture

Finally, I have also run a debug of the pptp connection which is stuck on "ConfReq".

pptp debug

Is there a bug with that specific PPTP package on that kernel ? Has anybody got any idea ?

  • DO NOT post links to images; include TEXT of contents. What OS/version are you running? – Milliways Nov 7 '17 at 0:56
  • Linux 3.12.22+ works with my PPTP. Linux 4.1.19+ is the kernel that breaks my PPTP. – pHeoz Nov 7 '17 at 20:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.