I've had Pi-Hole on my pi to some success but after a while of inaction my pi cannot connect to the internet now. Unsure what will help, as I've tried what I thought were all the obvious things.

I'm on the network, arp-scan shows the other devices, I can ping them. I cannot use chromium out though, nor can I ping My router has IP address and modem

cat /etc/resolv.conf shows the following:

nameserver nameserver fe80::1%eth0 nameserver fe80::1%wlan0

ip route show gives this:

default via dev eth0 default via dev eth0 metric 202 dev eth0 proto kernel scope link src metric 202

Chromium had been saying DNS or proxy or firewall may be the issue. It has since dropped the DNS complaint but I am still no better off.

Thanks in advance for the help.

  • can you ping www.google.com successfully?
    – guyd
    Nov 7 '17 at 6:47
  • Can you show the output from ifconfig please? It's unusual these days to have a modem and router, which is sitting the DHCP and DNS? Nov 7 '17 at 8:57

Answer appears to be to update bind with sudo apt-get install bind to fix /etc/resolv.conf allowing dhclient to complete at boot.

See this post on the error dhclient was giving: irs_resconf_load failed: 59.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.