6

I have a problem when starting my Raspberry Pi (Rasberry Pi 3 Model B). Everything worked fine. After the last reboot I've got this error. Any help would be appreciated.

End Kernel panic - not syncing: Attempted to kill init

  • If you have a spare SD card and flash a new image on to that, does it work OK? Is using a new image an option? – Aurora0001 Nov 7 '17 at 16:28
  • This portion of the log only shows the CPU stopping after an error. The first error where you'll see a stack trace and more addresses is actually above it. I know the errors may scroll by pretty quickly, but is it possible you can get a picture of the first error before it goes offscreen? Sometimes this comes about due to installing a new kernel module, and can be addressed by removing it. And even if the goal is to get your original system back, Aurora0001's advice still holds. Testing a fresh image can identify whether this is a software or hardware issue. – jdonald Nov 7 '17 at 17:51
  • Thanks guys. I've followed Aurora0001's advice and everything works. Is it possible to fix old image somehow? – Maksym Kutyshenko Nov 8 '17 at 20:21
  • I think booting from a new SD-Card with a new image is no proper solution. I have exactly the same problem. The RPi booted without any problems. From one day to another I got this error. But most times I won't see anything and the display stays blank. This is the second time one of my sd-cards crashes in this way. That's why I'm interessted in repairing the image instead of formatting the card. It seems to be that the Pi can't read the sd-card properly. Maybe it's a partition problem? – rweisse Feb 27 '18 at 15:38
  • 1
    On your picture top right corner, the yellow flash is an undervoltage warning. "If the power supply to the Raspberry Pi drops below 4.63V (+/-5%), the following icon is displayed." raspberrypi.org/documentation/configuration/warning-icons.md – Fabian Feb 28 '18 at 22:50
3

The problem could have several reasons. Until now I found out the following:

  1. Some 16GB SD-cards seem to have problems after apt-get upgrade && reboot Have a look at: https://github.com/raspberrypi/linux/issues/1416
  2. Sometimes the power supply causes problems like this. You should try another one if yours is to weak (5V and at least 2 Ampere for Raspberry Pi 3 Model B).
  3. One of the sd-cards partitions could be damaged.
    • In my case I took the sd-card, mounted it on a Linux system and backuped all my data at first because there is a chance that following commands will produce some data lost on your card.
    • After that I listed the partition names of the sd-card. Simply open a terminal and type lsblk or df -h
    • Usally the card name is mmcblk0. In this case the name of the boot partition should be mmcblk0p1 and the name of the root partition mmcblk0p2.
    • Now you have to unmount them. Type: umount /dev/mmcblk0p*
    • After that I run fsck on every partition in this way: sudo fsck /dev/mmcblk0p1 && sudo fsck /dev/mmcblk0p2
    • This command will check the filesystems of your card and offer you the opportunity to fix errors. In this case you can force the program to fix all errors automatically (type a Enter) after the first error was found or type y for every single error to fix.
    • Hopefully your system will boot now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.