2

I'm trying to use Ublox Neo 6m GPS module in my Raspberry Pi 3 Model B, running Raspbian Jessie for my project.

I've connected Vcc 3.3V to GPS's VCC, Ground to Ground, RX to TXD and TX to RXD.

Then I tried configuring the connection by following some tutorials, but none of them are working.

I tried removing console = ttyAMA0,115200 from /boot/cmdline.txt and installed gpsd.

While running the command cgps -s I'm getting GPS timeout.

This is my first time working with a RPI. Any detailed tutorial of my configuration would be a great help!

1

cgps doesn't communicate with your gps. It talks to the gpsd daemon, which is responsible for communicating with your GPS. Some diagnostic steps you can take:

  • Does /dev/ttyAMA0 exist on your system? It may be called /dev/ttyS0 if you're on a Pi 3 with a recent kernel. See this document for more information.

  • Can you connect to the GPS manually? The document linked in the previous bullet point has instructions for using screen to do that.

  • Are you running gpsd? And is it configured with the correct serial port?

  • I tried ttys0 and same thing occurred. Can you please tell me how can I determine if my GPS is connected or not? lsusb doesn't show any specific device that can be my GPS module – Mufad Nov 8 '17 at 13:52
  • Your device isn't connected via USB, so of course that won't show up in the output of lsusb. Did you read the "RPi Serial Connection" document? That has pretty much all the information you need to interact with serial devices. If that doesn't help I don't have much I can add. – larsks Nov 8 '17 at 14:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.