1

I configured the file /etc/network/interfaces with this as follows:

auto eth0
allow-hotplug eth0
iface eth0 inet static
address 192.168.1.111
gateway 192.168.1.254
netmask 255.255.255.0
dns-nameservers 8.8.4.4 8.8.4.4

and I disabled the service called : dhcpcd. If I disconnect the ethernet cable and wait a few minutes, the Raspberry goes online with another IP : 192.168.1.86. Why is this happening? I don't have any idea.

  • 1
    You probably haven't disabled dhcpcd; your settings look improbable, to say the least. You don't say which OS, but you may not even have eth0 Even though I think static IP addresses are a bad idea, if you REALLY must set up see How to set up Static IP Address – Milliways Nov 9 '17 at 11:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.