0

I've been researching this a lot and it seems I'm the only one with this specific issue with my Raspberry Pi on my Wi-Fi network.

As I speak I have just reinstalled Raspbian Strech onto my Raspberry Pi 3 for the fifth time. You see, every time I reinstall Raspbian Stretch and then connect to my WiFi, my network will be fine for a certain amount of time. But then all a sudden, if I have to reboot the Raspberry Pi via unplugging and replugging or I just leave it alone for half-a-day, then every device I own will say it's connected to the internet, but then lose access to DNS servers causing everything to basically lose internet access - even though it says I still have internet access.

Now what's strange about this, is that it affects my router on the local level too. So it comes to a point that I can't even Remote Desktop or SSH, and I think the same would happen if I remote into my other Windows devices as well. This is a very strange phenomenon and to my knowledge, again, this is only happening to me.

At first, I thought that it was a simple screw-up in my router, but then I discovered that indeed my Raspberry Pi is a direct cause as soon as it connects to my Wi-Fi. So then I was researching the limit on how many devices the average Wi-Fi router can handle. Thinking that I would have to upgrade my router. But then I come across articles like this that say the average Wi-Fi router can handle up to "250 connected devices" wirelessly, and four wired.

So what gives? Is this the Raspberry Pi's fault or is it my router? Back, in the beginning, I only installed Ubuntu Mate because I preferred Ubuntu, but then only my desktop couldn't connect to the internet, but that was fixed when I connected my desktop to a VPN and then the connection reset.

As far as I can tell this can't be fixed by commands such as "winsock reset" on the command prompt. I've tried multiple times, even calling up my ISP when this first happened. It's important to note that, even though the Raspberry Pi cannot handle it - and I do not think this is the trigger - I use my Raspberry Pi to make a Minecraft PE server. But if this was the trigger, it would lose internet access almost immediately. But when I first tried this it stayed up for hours. So maybe there was no point in bringing that up. But it's necessary to tell you everything I'm doing to diagnose this issue.

So, is this a problem with my router or Raspberry Pi? The version I'm currently running is "September 2017" (why is there no version number?), the latest as of this post. And the connection is wireless, not wired, as I ran out of ethernet cables. And my desktop is the only device wired to my router.

The type of wireless router I have is a Netgear "N150 Wireless Router WNR1000 v3."

  • 1
    What are you running on your RPi? Are you by any chance running PiHole? The symptom of other devices gradually losing internet connectivity sounds a lot like the DNS cache on each device expiring entries, and connecting to a malfunctioning DNS proxy (your RPi) to refresh. When you say you "can't remote" to the RPi, are you using the IP address or name of the device(s)? Are you running a DHCP server (e.g. dnsmasq) on your RPi when this occurs? If you manually configure one of the other devices to use known-good DNS (e.g. 8.8.8.8), does that device work while others fail? – bobstro Nov 9 '17 at 20:16
  • Specifically, I'm running a Nukkit Minecraft server (yes I know the specs of a Raspberry Pi are not qualified for a Minecraft server but I'm experimenting.) I do not know the details of how a Nukkit server runs, but it's coded in Java. And I have to port forward the private IP (that changes every time I reset my RPi) and the port number is 19132. It's important to note that I like to SSH and remote desktop into my Raspberry Pi anywhere, so I have to port forward 3 different ports on my router in order to get full access to it. Maybe that's the cause of the router issue? – Mr. El Nov 11 '17 at 14:34
  • Although now I'm only port forwarding the Minecraft Server and the remote desktop connection as those are the most important (to me) ports I have to forward and now I'm not getting any issues. Perhaps the problem occurs when I port forward the SSH port (22) on my router. And no I don't believe I'm running PiHole. – Mr. El Nov 11 '17 at 14:36
  • You'll have to do a bit of troubleshooting then. 1st big question is whether your other devices actually lose network connectivity or just DNS when this occurs. Can you ping to/from the devices by IP address? Can you ping your router? Can you ping the Internet (e.g. 8.8.8.8)? If you can, again, I'd start looking at DNS problems. Pull up and review the IP and DNS settings on each affected machine. Nothing you've described sounds like it should cause these problems. – bobstro Nov 11 '17 at 20:35
  • Since you guys keep mentioning DNS then, I guess that has to be the issue. Maybe it would've been better to post this on a networking version of Stack Overflow. I'm not having this issue anymore but to prevent this should I change my DNS to OpenDNS? – Mr. El Nov 11 '17 at 22:13
1

First, I have been running multiple Pi and NEVER "have to reboot the Raspberry Pi via unplugging and replugging"; indeed they run for months, even with upgrades.

cat /etc/os-release will show OS and cat /etc/rpi-issue will display the original image installed (mine is 2017-08-16) although this has been updated; uname -a will show kernel version.

You haven't specified how you configured networking, so it is difficult to comment on that.

Apparent unresponsiveness for ssh and other protocols in NOT due to the Pi, but often due to normal network "sleep", and often due to the client.

It is usually possible to "wake up" after a short delay, ping may help. On my Mac ssh sessions often appear unresponsive after the Mac has been to sleep, but I can establish a new connection immediately on a new terminal, indicatinfg the Pi is still there. There are settings to enable keep alive (this is a normal Linux option) if this is a concern.

  • It's not that, XRDP works all the time when it's powered on and even I can't connect to that. And I'm saying as soon as I boot up the Raspberry Pi I can't connect to anything locally because EVERYTHING disconects from the internet down to the local level. No SSH or XRDP, no youtube and FaceBook. And I unplug and replug it because it's faster than connecting a display mouse and keyboard and opening up a terminal to type "sudo reboot". Once I have remote desktop, XRDP, running I disconnect all those things so that way my desktop can have all it's monitors back. – Mr. El Nov 9 '17 at 11:54
  • @Mr.El We don't care what other devices you use, but you need to explain HOW you configured networking on the Pi. I don't use either, but AFAIK xrdp is incompatible with the RealVNC included in Raspbian. – Milliways Nov 9 '17 at 12:05
  • Raspbian is version 9. Image is 2017-09-07. Kernal is 4.9. RealVNC does not work with my Raspberry Pi for some reason, that's why I use XRDP and it works. All I did was enter my WPA2 password. I set everything to dynamic to automatically give me IP addresses. I don't know what details I need to provide. Please explain. – Mr. El Nov 9 '17 at 12:06
  • I just set my SSH to boot automatically on start (could that be the issue? I mean now that I think about it network issues happen as soon as I set SSH to boot up autmatically), and install XRDP then transfer my files with WinSCP. That's it! – Mr. El Nov 9 '17 at 12:12
  • Welcome! I'm sorry but your question isn't very clear. All I get from it, is that you're having problems with DNS. Could I suggest you edit the question and include greater detail - perhaps with fewer words? Just stick to the detail. As Milliways asked how did you configure the network? How do clients get DNS addresses. – mintyfreshpenguin Nov 9 '17 at 18:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.