1

I am developing a Bluetooth application using Qt5 on Raspberry Pi3. I have implemented my own Pairing agent which will automatically accept the pairing request from the remote device.

The code is working fine, but still the default dialog box for pairing confirmation pops up and when CANCEL is pressed/ the window is closed and it disables the Bluetooth Icon. However the Bluetooth functionalities are all working. I've already tried several solutions such as changing the agent display type and all, but it doesn't seem to have any effect. Is there any way to stop displaying the default pop up?

  • I'm not a PIXEL or LXDE user but presuming the "bluetooth icon" is embedded in a taskbar, I'd try removing it. Quite likely it is part of the app which pops up the dialog, so if you want your own such icon you will have to code that. – goldilocks Nov 9 '17 at 15:02
  • Actually I'm not that much concerned about that icon...and I don't want to replace that icon too...The application I've made correctly handles the BT function. I just wanted to know whether there's any way to stop the default popup window from showing up. Because it simply makes my application pointless as I want to have no human interaction during the pairing procedure other than initiating the pairing. – Mahesh Mohandasan Nov 10 '17 at 6:45
  • To clarify my point: I would guess that the icon widget and the popup are part of the same program and that the reason the popup occurs is because that program is active and it is active because the widget is there in the taskbar. I'm sure you've added things to a taskbar somewhere, even if not in PIXEL. They are not just icons, like a sticker. They have some functionality, e.g., a "notifications" widget might handle general notifications and create a popup for them. I suspect this is similar, although again, that is just a guess and I've never used PIXEL. – goldilocks Nov 10 '17 at 13:55
  • I got your point. I'll try to find and disable the default program, though I have tried it once or twice with no success. However will focus more on this point. – Mahesh Mohandasan Nov 13 '17 at 4:16
  • @goldilocks removing the icon from the tray worked! Thanks for that. :) – Mahesh Mohandasan Nov 13 '17 at 5:09
1

As in the discussion in the comments, the pop up is associated with the default blue-man application in Raspberry Pi. Just right click on the BT icon in the tray and remove and your default application is gone and you can use your own application for BT functions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.