1

I'm installing LIRC on my Raspberry Pi 3B.

I ran:

apt-get install lirc
apt-get install lirc-x

Then I followed a number of web examples: Energenie ener314-ir - The IR Board I'm using LIRC - Raspberry Pi and quite a few others.

However, I fall down on each one as they all say at some point:

edit your /etc/modules

and

/etc/lirc/hardware.conf

I don't have these files. I don't even have an /etc/lirc/ folder.

I'm a new to Raspbian and Linux in general so I'm not sure how to proceed to debug this problem.

1

Everybody has /etc/modules, it's a system file. You are probably not looking in the correct location.

Basically, from the root of the file system are a number of system folders, and a folder called home. Home is where YOUR files and folders are, including Downloads, Documents and such. You need to go into the system folder called etc. The simplest way to do this is via the command line.

  1. Open a terminal. Look for a black rectangle icon called term.
  2. Choose your text editor and launch it by typing this command:

sudo name_of_text_editor /etc/modules

Some people use leaf, some people use nano, some people use vi. If your text editor doesn't launch, use gksudo instead of sudo.

  • Yes that worked. I think I confused files with folders – Richard210363 Nov 12 '17 at 13:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.