I recently purchased a Raspberry Pi 3, which I understand to have the BCM2837 chip. When I purchased a codec from raspberrypi.com, I was asked to run:

cat /proc/cpuinfo

I was surprised to see the following output at the bottom:

Hardware : BCM2835 Revision : a22082 Serial :

Why should I see this output from a new Raspberry Pi 3, instead of the BCM2837 chip?

  • New Pi users often poke around and worry needlessly about trivial issues. If you search you will find thousands of discussions on Chip ID - all FUTILE as the data is unavailable, except to those few who have signed NDA. This was an issue some years ago, and caused confusion with driver ID. AFAIK the value is USELESS, and all Pi show the same; the Revision can be used to determine what board is in use, if this matters. gpio -v will show this. – Milliways Nov 12 '17 at 4:58
  • Mine says the same thing using the latest kernel (4.9.61). – goldilocks Nov 12 '17 at 7:21

Quoted from a Raspberry Pi engineer :

It's just a kernel/device tree anomaly. Upstream have chosen to denote all the Pi's as BCM2835, whereas the original Pi specific kernels would display BCM2708, BCM2709, or BCM2710 as appropriate.

Whether it is more correct to use 2708/9/10 or 2835/6/7 is also sometimes debated - the former are the silicon, the latter are the packaged chip (which in some non-Pi cases also included an independent RAM die within the same package).


For info my Pi3 does the same 'cat /proc/cpuinfo' :

Hardware : BCM2835 Revision : a02082


I did some more digging and found this. Basically, the 'revision code' is the only useful bit of information. Look it up in this table to confirm what you really have. In your case, it's a Pi3B manufactured by Embest.

Code Model Revision RAM Manufacturer

900021 A+ 1.1 512 MB Sony UK

900032 B+ 1.2 512 MB Sony UK

900092 Zero 1.2 512 MB Sony UK

900093 Zero 1.3 512 MB Sony UK

9000c1 Zero W 1.1 512 MB Sony UK

920093 Zero 1.3 512 MB Embest

a01040 2B 1.0 1 GB Sony UK

a01041 2B 1.1 1 GB Sony UK

a02082 3B 1.2 1 GB Sony UK

a020a0 CM3 1.0 1 GB Sony UK

a21041 2B 1.1 1 GB Embest

a22042 2B 1.2 1 GB Embest

a22082 3B 1.2 1 GB Embest

a32082 3B 1.2 1 GB Sony Japan


You shouldn't. That's the chip for the original Raspberry Pi.

  1. Make sure you have a Raspberry Pi 3. Compare yours to the picture below. Check the markings on the chip and the PCB. enter image description here
  2. The output from cat /proc/cpuinfo will also tell you how many cores you have. RPi3 has 4 cores.
  3. You could have an outdated OS that doesn't have the proper drivers for the CPU, causing it to not getting recognised properly. Which version of which OS are you running? Where did you get the installer from?
  • 1
    Have you ACTUALLY tried this on a Pi3? – Milliways Nov 12 '17 at 3:53
  • @tlhIngan Yes, this is a Pi3 I purchased last week from Amazon; the vendor was Prestige Milano: link. It matches the picture above; the chip was stamped BCM2837. I have run 'sudo apt-get update' and 'sudo apt-get upgrade' several times. When I run 'cat /proc/cpuinfo' I do see information for four processors (0-3). I got the installer from NOOBS. Here is the output from 'uname -a': Linux xxxpi 4.9.41-v7+ #1023 SMP Tue Aug 8 16:00:15 BST 2017 armv7l GNU/Linux. Do you have any other suggestions? – D. MacGrouther Nov 12 '17 at 4:44
  • @Milliways No, but this guy did --> raspberrypi.org/forums/… , says it's a 32-bit mode issue. – tlhIngan Nov 12 '17 at 4:44
  • @D.MacGrouther It's likely a legit Pi 3, it's just the OS drivers aren't recognising the CPU properly. – tlhIngan Nov 12 '17 at 4:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.