0

I set the static eth0 IP Address in my Pi by editing /etc/dhcpcd.conf file in my house

So i can connect in that address by ssh in my house(my Macbook is on wifi same router

but when i try to connect outside like cafe i cannot connect by ssh

and it said Operation timed out. what's the problem?

  • 1
    Sounds like you need to port forward ssh port on your router. Make sure you change your default pi password or your Pi will get hacked. – CoderMike Nov 14 '17 at 14:17
-1

Had similar problem, latest raspbian versions disable ssh by default. If you don't have screen/keyboard to start ssh by hand and add it to default init, then the easiest way is to mount the sd card on a computer and create a blank fine name ssh on the root fs. (source:ssh raspi documentation

  • Question says it works in their house - not from outside – CoderMike Nov 14 '17 at 14:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.