2

This question already has an answer here:

I tried to launch Minecraft Pi, I get a black window and nothing else happens. I'm using the pi-3 remotely with a VNC client, could it be related ? I'm new to Raspberry. I read that overscan enabled is sometimes the problem, disabled it, rebooted, nothing changed.

marked as duplicate by Gene, techraf, Ghanima Nov 15 '17 at 6:57

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

It sounds like you're using the default RealVNC server for Raspberry Pi. This does not support Minecraft Pi nor other OpenGL ES programs. Minecraft Pi is known to come out black on the client side.

Some time ago RealVNC released an alpha build which copied the resulting framebuffer over rather than relying on X. This makes it possible to see a Minecraft Pi window over VNC, but my experience was that it was unplayably slow even on a Pi 3 with a fast LAN.

As far as I know this feature never came out of alpha, but you can still try it. Enable "Experimental direct capture mode" from the VNC Server options under "Troubleshooting" (Thanks Andrew!)

Links:

  • In fact, I'm using TightVNC not RealVNC, but that's problably the same kind of problem, isn't it? – snoob dogg Nov 14 '17 at 23:08
  • 2
    The direct capture mode in RealVNC was released over a year ago, and the speed has improved quite a bit from the original alpha version. You simply need to enable "Experimental direct capture mode" from the VNC Server options, under "Troubleshooting". See realvnc.com/en/raspberrypi for more info. – Andrew Wedgbury Nov 14 '17 at 23:22

Not the answer you're looking for? Browse other questions tagged or ask your own question.