7

I have a legitimate subscription to Netflix, but even though I can login, I can't watch any content other than previews. If I try I get the message Error Code M7701-1003 when I try to watch anything. Does anyone have a good solution to this?

I have looked at a number of different forums and they talk about needing the widevine extension for Chromium, but non of what I have found on how to get it added seems to work. I have also read about the problem being that Raspbian is a 32 bit operating system as opposed to a 64 bit operating system. Are there any solutions out their?

  • This is a great question, likely applicable for many, or at least a reminder that the other question needs an update after five years. I'm not a Netflix user, but this article seems current. The downloading of Chromium+Widevine with wget step worked for me so maybe you could post more details of where you're getting stuck? FYI all of the tutorials that you find online for Raspbian are assuming 32-bit because it's a 32-bit OS. – jdonald Nov 15 '17 at 2:48
  • I have now got Netlix to work. One of the problems that I was having was with respect to down loading a version of Chromium with Widevine from Github.com. raspbain would not let me - giving me messages about untrusted software and not accepting my pasword to allow down load/ openning of file. I managed to get around that with some help from a tech wiz article as below: – Marpy Nov 21 '17 at 0:31
  • Here are easy directions for doing this in 3 steps: blog.vpetkov.net/2019/07/12/… – Ventz Jul 19 at 6:55
2

I am new at this and software/ operating systems and anything programming are far from my strong points but I managed to stumble along and get Netlix to work. I will explain as best I can as I worked on this on and off for a day and a half – getting bits and pieces from different sites and moving forward a step at a time. . One of the problems that I was having was with respect to down loading a version of Chromium with Widevine from Github.com. Raspbain would not let me - giving me messages about un trusted software and not accepting my pasword to allow down load/ opening of file. I managed to get around that with some help from Tech Wiz Time – pertinent part of which I added below as I can't find the link that got me there but did copy what I needed when I originally found it. I think I got their via comments to one of their You Tube video's.

chromium-build

A script to generate a chromium deb package from a standard Chromium build Usage: ./build-deb.sh deb_name version

e.g.: build-deb.sh chromium-browser_51.0.2704.91-0ubuntu0.14.04.1.7000 51.0.2704.91-0ubuntu0.14.04.1.7000

How to use installer.sh on Raspberry Pi inside Raspbian Pixel To minimize problems, I've created an SHELL Script to handle removal of Chromium Browser, Installing of KUSTI8 precompiled DEB file and CLEANUP. To use the pisetup.sh file, go to the Command Line and type the following:

wget https://raw.githubusercontent.com/TechWizTime/chromium-build/master/installer.sh sudo chmod +x installer.sh Then run the script: sudo ./installer.sh

CREDITS https://github.com/kusti8/chromium-build

aHow to watch Netflix on the Raspberry Pi TOPICS:ChromeChromiumNetflixWidevine

NEXT

I then had to install a user agent extension and make some other modifications based on an article I found on “The Pi”

https://thepi.io/how-to-watch-netflix-on-the-raspberry-pi/

As I tried different steps, I would attempt to run Netflix and get different error codes. Googling them gets you a description of what they are .

Netflix runs well on my Pi but for those that have issues with picture quality etc, the following tips from TechWiz time should help.

https://techwiztime.com/article/raspberry-pi/top-ten-tips-make-netflix-run-better/

1

Here are easy directions for doing this in 3 steps:

https://blog.vpetkov.net/2019/07/12/netflix-and-spotify-on-a-raspberry-pi-4-with-latest-default-chromium/

NOTE: Blog post keeps latest working library, and keeps updating them as they change, so check there for newer versions of the library.

And apparently because StackExchange cannot use links only, here is verbatim from the post (last updated as of: 8-17-19):

1.) Download the latest extracted ChromeOS libwidevine binary and extract it:

$ sudo su
# cd /usr/lib/chromium-browser
# wget http://blog.vpetkov.net/wp-content/uploads/2019/08/libwidevinecdm.so_.zip
# unzip libwidevinecdm.so_.zip && chmod 755 libwidevinecdm.so

NOTE: You can verify that these are the official versions from ChromeOS: https://dl.google.com/dl/edgedl/chromeos/recovery/chromeos_12105.100.0_elm_recovery_stable-channel_mp-v2.bin.zip

filename: libwidevinecdm.so

md5sum: 41c94b9ffa735fe4f412b7e9283dd2ff

sha256sum: 2245a2f5ba8452692e79f478d64adbeedaef5307cc73e81ffe64de69a7a53640

2.) Completely QUIT all Chromium windows and re-start it. Grab the “User-Agent Switcher for Chrome” extension: https://chrome.google.com/webstore/detail/user-agent-switcher-for-c/djflhoibgkdhkhhcedjiklpkjnoahfmg

Right click on the extension, go to “Options” and “Add” the following in the fields:
a.) New User-agent name: Netflix
b.) New User-Agent String: Mozilla/5.0 (X11; CrOS x86_64 11895.95.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.157 Safari/537.36
c.) Group: Chrome
d.) Append: Replace
e.) Indicator Flag: NFX

3.) Open a new tab, select the “NFX” profile (one time) from the User-Agent Switcher, and go to: https://bitmovin.com/demos/drm You should be able to see the movie on the left. You can now play Netflix, and Spotify

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.