2

I've wanted to config CUPS for my printer, but because I'm running a command-only version of Raspbian, I don't have access to the browser on this device.

I've followed the CUPS installation and config from this site.

So I've looked up my IP address, I pinged it from my other device - it worked. I've opened the browser, put the IP along with 631 port but there's an error: ERR_CONNECTION_REFUSED

Can I somehow change the config in cupsd.conf file to make it work?

  • It should be possible to remote into the Pi using SSH, then use a series of Linux commands to find and edit the file as you need. – Darth Vader Nov 17 '17 at 11:26
  • Well... I can connect to Pi directly and run nano cupsd.conf but that's not the point. I'd like to see CUPS website on another device - PC – Kamil Nov 17 '17 at 17:02
1

I know this is a rather old post, but I had the same issue. From what I can tell you need to "restart" cups after the changes, not just "reload"

sudo service cups restart

My guess is at some point you rebooted the pi which restarted the service and made it start working correctly.

0

Well, this is awkward.

After few hours I just connected the printer via USB and tried the webpage. I haven't changed the configuration and I don't believe that connecting the driver somehow matters but it works now:

cups webpage

EDIT:

I've just reminded myself that I followed the steps from here to install samba. Maybe it did the job.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.