My Raspberry Pi doesn't boot. I reisntalled Raspbian as I did the last time, when it worked correctly, and still it doesn't boot.

I was working with the GPIO when the display turned off, and after that I can't boot anymore. Also, it's not a issue of the power supply, as it worked fine, and still works when I connect it to my cellphone. The PWR and ACT LEDs are on during the first 1.5 minutes.

Anyone knows why can my Raspberry Pi won't boot?

  • You must have an SDcard with an OS on it inserted into the SDcard slot. The Raspberry Pi will appear as if it is not working, otherwise. Unfortunately, Raspberry Pi's do not display any 'POST' data to the graphics card like a normal BIOS does. I say this because I've had more SDcards die on me during freak accidents than I have had pi's die on me.
    – earthmeLon
    May 25, 2013 at 20:39

4 Answers 4


While working on GPIO you might have made a shortcut, causing protection fuse to blow up. It is reported that these fuses may need several hours or even few days to fully recover. So it is possible that your RaspberryPi will boot just fine if you leave it for couple days. Be sure to checkout troubleshooting guilde if it's not.


most probably you've burned your Raspi during your GPIO experiments. should have ordered two, then you always have a way to compare and check where the problem is.

on the other hand, getting new SD card is cheaper, and you may want to start from creating another SD card. then try to prove it works -- ask a friend to boot from your newly created SD card or ask someone who has Raspi and is willing to help, maybe send it to another city and back. if you still cannot boot with a proven to work SD card, then it's really a time for a replacement.

also, you might try to analyze your LED status using this guide.


I recommend you get one of these serial dongles off ebay for a couple of dollars (at least for next time).

If nothing is showing up there, you've probably damaged the chip.

Consider @Krzysztof Adamski's answer. You can temporarily solder a wire across the main polyfuse if you don't want to wait a couple of days to confirm whether it's dead.


Using a multimeter, test the F3 Polyfuse following these instructions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.