2

I have a little bit of an issue displaying the Raspberry Pi on a 1280x272 screen. The monitor is about 9" and has a HDMI input.

I have tried connecting it before startup, and it doesn't seem to work. The Pi defaults to 800x600 in that scenario.

Next, I edited the config.txt file and added this line at the bottom:

hdmi_cvt=1280 272 60

Now, i get a display that is shifted all the way to the left (imagine taking the image you should see,and doing a horizontal shift until almost everything is off the screen). When I change the refresh rate to 30, I can see more of the screen, about 20%.

The colors are way off (looks like some mix of inverted and blurred).

BUT, using my Windows 10 laptop, ubuntu 16.04 laptop or ubuntu 16.10 desktop, the monitor is recognized and works properly.

Does anyone have an idea of how to fix this or what may be wrong? I have a feeling that part of the problem may be the HDMI timing being off. Is there a way to get that information from the computers when they're connected to it?

A little more info:

The main changes in my config.txt are increasing the HDMI output power (config_hdmi_boost) to 9, and forcing the specific hdmi mode (hdmi_group and hdmi_mode) that was just added.

Output of edid:

    Enabling fuzzy format match...
    Parsing edid.dat...
    HDMI:EDID version 1.3, 0 extensions, unknown aspect ratio
    HDMI:EDID features - videodef 0x81 !standby !suspend !active off; colour encoding:RGB444|YCbCr422; sRGB is not default colourspace; preferred format is native; does not support GTF
    HDMI:EDID ignored unknown descriptor tag 0x10
    HDMI:EDID ignored unknown descriptor tag 0x10
    HDMI:EDID ignored unknown descriptor tag 0x10
    HDMI:EDID does not yet know monitor vertical range, setting to default 24 to 120Hz
    HDMI:EDID failed to find a matching detail format for 1280x272p hfp:120 hs:48 hbp:40 vfp:21 vs:2 vbp:30 pixel clock:29 MHz
    HDMI:EDID calculated refresh rate is 60 Hz
    HDMI:EDID guessing the format to be 1280x272p @60 Hz
    HDMI:EDID found unknown detail timing format: 1280x272p hfp:120 hs:48 hbp:40 vfp:21 vs:2 vbp:30 pixel clock:29 MHz
    HDMI:EDID established timing I/II bytes are 00 00 00
    HDMI:EDID standard timings block x 8: 0x0101 0101 0101 0101 0101 0101 0101 0101 
    HDMI:EDID adding mandatory support for DMT (4) 640x480p @ 60Hz
    HDMI:EDID filtering formats with pixel clock > 162 MHz or h. blanking > 1023
    HDMI:EDID no known preferred format has been set
    HDMI:EDID filtering preferred group has been changed from Invalid to DMT
    HDMI:EDID best score mode initialised to DMT (4) 640x480p @ 60 Hz with pixel clock 25 MHz (score 0)
    HDMI:EDID best score mode is now DMT (4) 640x480p @ 60 Hz with pixel clock 25 MHz (score 36864)
    HDMI:EDID preferred mode is updated to DMT (4) 640x480p @ 60 Hz with pixel clock 25200000 Hz
    HDMI:EDID has only DVI support and no audio support
    edid_parser exited with code 0
0

Have you tried editing the overscan settings in the config.txt file to see if they can shift the screen back to the right? Example settings (defaults from my config.txt) might be...

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

You might try, for instance, uncommenting the overscan_left and overscan_right and playing with different values to see what it does to help (or not).

Just a thought! Good luck.

  • Sorry for the late response. I got it working in a round-about fashion, one which I don't understand. Overscan on it's own did not do the trick. This display is 1280x272 (regular computers show this too). I created a custom hdmi mode for it, and set it to 1280x1080, and used the overscan settings to make it fill properly. I also set it up for "interlaced enabled", "enable blanking" and "margins enabled". The combination of these seemed to make it work. Now, when i run xrandr, the resolution it gives me is 1280x530 (about), which I assume has to do with the interlace, but don't understand. – engineer14 Nov 29 '17 at 4:13
  • Awesome! Glad you got it to work! If possible, can you write up a detailed answer so that others might benefit from it? This is such an odd monitor size that there will inevitably be someone else out there that runs into it in the future. They will appreciate any details you can give them! – MrChips Nov 29 '17 at 4:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.