I just bought a Raspberry Pi and realized that I am out of ethernet cables, so I decided to try my hand at connecting it to my home's WiFi network.

After many attempts, and reimaging my SD card multiple times I have not been able to figure out the issue.

I am mostly surprised that the tutorial provided by raspberrypi.org does not help at all either. Any advice?

closed as unclear what you're asking by Steve Robillard, Milliways, techraf, joan, Dmitry Grigoryev Nov 28 '17 at 8:47

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    I'm assuming that if you are running Stretch 'lite' you are intending to use this as a headless device. Have you tried the instructions HERE>>(raspberrypi.stackexchange.com/questions/10251/…) for setting up the device to boot up into WiFi automatically after imaging the SD card? If none of that is working, then you may have a bad Pi with broken WiFi hardware. – MrChips Nov 25 '17 at 5:13
  • @MrChips I've tried that multiple times, and then again after you mentioned it. But I still have nothing. – Zachary Elkins Nov 25 '17 at 18:11
  • Zachary - There is a good chance you may have a broken Pi. Do you have access to another board? If so, that may be your next step. Sorry you are having so many problems! – MrChips Nov 25 '17 at 18:46
  • @MrChips - I don't know what was up with my pi but after my probably ninth or tenth time reimaging my sd card and going through all the steps of the original tutorial it just decided to work all of the sudden. Very frustrating, but at least it has resolved. – Zachary Elkins Nov 25 '17 at 18:47
up vote 1 down vote accepted

After going through the reimaging and reconfiguring the /etc/wpa_supplicant/wpa_supplicant.conf process for maybe the tenth time it just decided to work all of the sudden. Very odd.

  • 1
    Glad to see it worked for you! Sorry it was such a pain. You may want to watch it a bit though, as it could still be a flaky WiFi connection if it's a hardware issue. Heat, cold, etc. can do funny things to a board that is on the bubble of being bad. Good luck! – MrChips Nov 25 '17 at 18:53

Not the answer you're looking for? Browse other questions tagged or ask your own question.