0

I recently bought a Raspberry Pi 3 Model B and started to set it up. I followed some tutorials and finally was able to access it remotely without having to plug it to a monitor, a keyboard, a mouse...

Everything is okay but it just bothers me a little bit that whenever I reboot it or I don't use it for some time I have to ping it on the computer before being able to control it remotely. If I don't ping it, connection fails.

I thought that maybe it was in some kind of "sleep" mode, but when searching for it I found out that it doesn't have that feature. So I was wondering if someone could help me, maybe soemone could help me fixing this or coming up with something to ping it every 5-10 minutes for example.

It's not a big problem but is something I'd like to be solved. Thank you for your attention!

UPDATE: Just did a clean installation and now it works fine and can be accessed remotely at any time. Thanks to anybody that tried to help!

  • Sounds like an issue with your network, what is your network setup ? – onion Nov 27 '17 at 13:23
  • If you have a Mac, I can go step by step through it with you. – Darkest N2O Nov 27 '17 at 15:06
  • Hey guys I don't have a Mac Darkest and onion, I don't really know what you mean with my network setup :/ – Alex Cabello Nov 27 '17 at 20:06
0

Plug the raspberry pi into your router with an Ethernet cable. Fire the pi up and the lights on the Ethernet module should start blinking. Then goto your routers webpage and insert you username and password. Find connected devices, then use the IP address for your raspberry pi in putty.

Another option is to see if the green lights blink for some time after you power up the pi. If they don't make sure you are using a suitable adapter for the micro usb cable. 5V 2.5A for a pi3

If this dosen't work still, then check that your SD card has the image properly installed. I use etcher to burn zip images to SD cards.

  • Well everything seems okay, I already made the Pi's IP static so that shouldn't be too much of a problem. Lights blink accordingly when I boot it up and I can connect through putty without having to ping it the first 10-15 minutes, then I have to ping it again if I want to control it remotely. I might try to do a clean installation. – Alex Cabello Nov 27 '17 at 20:11
  • If you wanted to use the desktop mode, you could always ping the pi, enable VNC and login to it. Then on the computer (the one your sshing from) download and login to VNC. This will work without needing your raspberry pis ip address as long as you log in. – Darkest N2O Nov 27 '17 at 21:34
  • Yeah that’s what I’ve been using the last couple days and it works okay. I just want it to be operative the full day just in case I have a little web server and if I want to access it remotely from my mobile phone for example I don’t have to ping it. – Alex Cabello Nov 28 '17 at 5:36
  • So you don't need anymore help? There is an app on phones and tablets also called VNC – Darkest N2O Nov 28 '17 at 15:56
  • Not anymore, it seems that reinstalling everything worked perfectly. Last time I downloaded NOOBS and installed Raspbian, this time I just took the Raspbian OS image and burned it into de Micro SD and it looks like that might 've done it so thank you! Didn't know there was VNC available for mobile phones, might give it a try, seems cool to be able to access it graphicly from my mobile phone! – Alex Cabello Nov 29 '17 at 17:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.