1

I know it's not much info but look for a lot of stuff but can't understand

SSH stop working from all device (OSX, IOS, PC) I have this error

:.ssh kevin$ ssh pi@192.168.1.2
ssh: connect to host 192.168.1.2 port 22: Connection refused

Tried sudo rm known_hosts but no help

When I do a scan I don't see the SSH port .... I have no clue why.

FTP is still working and VNC is kind of working (When I login I get logged out after a few sec, and can't even see the whole screen anyway)

Is the only solution is to connect the raspberry pi to a screen and reinstall SSH?

Thank you

Update :

Raspberry pi led is red

Port

 Open TCP Port:     21          ftp
 Open TCP Port:     53          domain
 Open TCP Port:     80          http
 Open TCP Port:     139         netbios-ssn
 Open TCP Port:     445         microsoft-ds
 Open TCP Port:     5900        rfb

Boot folder

1

Connection refused in combination with port 22 not showing up in a port scan generally means that SSH is not enabled on the system. Reinstalling SSH probably won't help you, but you could try to re-enable it.

If you don't want to connect a screen, you can power down the pi, take the SD card out and mount in on a pc, put a file called ssh in the /boot directory and put it back in your Pi. This should enable the SSH server.

  • It’s seems like a great solution, where do I fine the original ssh file for the boot folder though ? Or I just create one is it ? – Kevin Nov 27 '17 at 21:17
  • You don't. Just create an empty file called ssh there. It triggers the pi to enable the SSH server. – 88weighed Nov 27 '17 at 21:18
  • Unfortunately same issue, also forget to mention but the Raspberry PI led is red, I also added a screenshot of the boot folder – Kevin Nov 27 '17 at 21:57
  • 1) just red LED or also LAN LEDs? 2) check if ssh is running on the system: systemctl status ssh 3) check if port gets blocked iptables -L – user236012 Nov 27 '17 at 23:42
  • the ethernet was ok (one side green one orange) I have normal trafic (FTP / HTTP etc) I plugged to a screen but couldn't start the X interface. so I just formatted everything and started over... thank you. – Kevin Nov 28 '17 at 10:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.