2

I have a 16 GB SD card and I installed it on the Raspbian operating system. But when I type df -h on the terminal screen it shows 4.5 GB.

Operating System : Raspbian GNU/Linux 8 Jessie

$df -h

Filesystem           Size  Used Avail Use% Mounted on
/dev/mmcblk0p2       4.5G  4.1G  152M  97% /
udev                 435M     0  435M   0% /dev
tmpfs                 88M  8.6M   79M  10% /run
tmpfs                437M     0  437M   0% /dev/shm
tmpfs                5.0M  4.0K  5.0M   1% /run/lock
tmpfs                437M     0  437M   0% /sys/fs/cgroup
/dev/mmcblk0p1       256M  209M   47M  82% /boot
  • did you expand the filesystem? sudo raspi-config – Steve Robillard Dec 2 '17 at 23:42
  • How will I do ? What should I do after the "sudo raspi-config" phase? – Alparslan Bagriyanik Dec 3 '17 at 0:01
  • the first option in raspi-config is expand root filesystem – Steve Robillard Dec 3 '17 at 0:02
  • Is there any reason you installed an obsolete OS? (I also wonder how) – Milliways Dec 3 '17 at 0:12
  • @Milliways: How? Here are all the older images of rapbian lite – SBF Dec 3 '17 at 11:13
1

OK, so this is a fairly standard problem on older versions of Raspbian.

You need to tell the system to expand the root filesystem to use the available space on the SD card. To do this, follow these instructions:

(Optional, but recommended: Go out and re-image with the latest version of the Raspbian OS. As of this writing, that would be Stretch. Jessie is outdated at this time. With Stretch you shouldn't see this problem as it will auto-expand for you.)

For older versions:

  1. Boot into the Pi and login as the pi user (password=raspberry)
  2. At the command prompt, type sudo raspi-config
  3. Select the first option Expand Filesystem
  4. The app will go out and apply the necessary changes, then reply with the message Root partition has been resized. The filesystem will be enlarged upon the next reboot
  5. Select OK, then select Finish
  6. When prompted to reboot, select Yes

Your Pi will reboot. When you login next time, try the df -h command again. The root filesystem should expand now to use up the rest of the SD card space.

Write back here to Let us know if this works for you (and if so, please mark this as the answer).

Good luck!

  • 2
    In fact it is an uncommon problem. All recent versions of Raspbian automatically resize the filesystem on initial boot. – Milliways Dec 3 '17 at 6:27
  • @Milliways - You are correct. I have amended my answer to clarify. Thanks! – MrChips Dec 3 '17 at 16:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.