0

I want to turn off auto white balance for my raspivid stream. However, when doing that, the image turns completely black. Why? And how do I fix this?

0

Here's another question/answer similar to this one that seems to fix an issue like yours. Maybe that fits your situation? If so, please let us know. Thanks, and good luck!

  • Yes, I know that question. Did not help. I have tried -awb off -ex off -sa -10 and different combinations. I think it is very weird that turning awb off messes at all with the exposure. – Arne Dec 3 '17 at 19:56
  • I also tried to use -awbg X to set the awb gains. But I get an error that the option is not known. Google indicates this is a common problem... – Arne Dec 3 '17 at 20:19
0

On the official forums I got the answer. I need to set red and blue gains in the awbg parameter: -awbg '1.0,1.0'.

The parameters of course can be tweaked to give the desired appearance.

The answer is actually hidden in the official documentation: https://www.raspberrypi.org/documentation/raspbian/applications/camera.md

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.