1

I managed to use my Raspberry Pi Zero W as hotspot. I did this headless by using SSH and my Ubuntu 17.10 laptop.

All I installed was nginx which serves as a web server as well as hostapd and dnsmasq to use it as a hotspot.

After rebooting the system I can no longer access the Raspberry Pi via SSH. I see that the hotspot works since my laptop detects a new wi-fi network but it does not recognize the Raspberry Pi via USB anymore. Ubuntu says "Cable unplugged" when opening the Network.

I tried a lot of tutorial the last hours but I have still not managed to access it via SSH.

How could I possibly access my Pi via SSH again? What for information would you need? I really do not want to repeat the whole process from copying the image file to the SD card to setting up all the programs I need.

I would be really glad if someone would help me to solve this problem!

  • 1
    What do you mean with "does not recognize the Raspberry Pi via USB anymore" ? Does you machine connect to the hotspot, do you get an IP and does the Pi respond to pings ? – onion Dec 5 '17 at 7:57
  • @onion Before setting up the hotspot I could access the Pi via SSH using the terminal ssh pi@raspberrypi.local and everything just worked fine. After plugging in the USB cable Ubuntu showed an Ethernet Network I could connect to. But now it is not possible anymore. Any suggestions? – Samuel Dec 5 '17 at 12:41
  • @Samuel Consider moving/integrating any details from comments into the original question (with, perhaps, an indication that it is extra data) it could help to reduce the chances of the question being closed because it is too broad or unclear what you are asking.,, – SlySven Dec 19 '17 at 2:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.