0

I use a Raspberry Pi Zero W with Raspbian Stretch Lite 2017.11.29. I set up a SSH connection from my laptop to the Pi via USB to configure it.

Now I just do ssh pi@raspberrypi.local on my Ubuntu 17.10 laptop to connect to the Pi. Everything works fine!

Since I want a wireless adapter with a static IP address I added the following to the file /etc/network/interfaces

auto wlan0
iface wlan0 inet static

    address 192.168.255.1

    netmask 255.255.255.0

    wireless-mode Master

    wireless-power off

After doing that I can no longer access my Pi via SSH. My computer also does not find my Pi anymore if I connect it via USB. What can I do to make it work again?

Help of any kind would be highly appreciated.

  • What to say? Perhaps revert your changes? – joan Dec 5 '17 at 15:50
  • @joan I wanted to do that. But when I opened the file again my changes where gone. So I do not know how I can revert the changes. The file looked like before my changes. – Samuel Dec 5 '17 at 15:58
  • It sounds like you have more than one Pi connected and are using the wrong one, or you are using something like NOOBS, in any case you need to find the file you actually edited and revert the change. – joan Dec 5 '17 at 16:01
  • @joan I am sure that I changed the file /etc/network/interfaces doing sudo vim /etc/network/interfaces. I have only one Pi and I am not using NOOBS. – Samuel Dec 5 '17 at 16:06
3

You obviously didn't read the contents of the interfaces file, before modifying it.

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf

See How to set up networking/WiFi which contains default files for Jessie and Stretch, although in Stretch the interfaces file does nothing and can be deleted.

It is unclear from your question whether you are trying to setup the WiFi as an Access Point, or to access a network. If the latter your settings are wrong/incomplete; if the former additional software is required.

The following describes How to set up Static IP Address

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.