2

I am using Raspbian Stretch on my Pi 3. It has been working fine for last couple of months. However, recently I am experiencing a weird issue.

I cannot SSH to it. When I connect, it shows the login window, asks for user name (login as:) and as soon as I put the user name, the connection is terminated.

And, if I'm already connected via SSH, the commands fail to work. So far I saw cd working for me. other commands are failing. For example, ls gives an error as no command /bin/ls

Also, if I manage to open the Samba share before the Pi stops, I can continue using it. However, I cannot connect to the Samba share if I try after the Pi stops responding. The two LEDs keep glowing continuously.

Any help?

  • Can you please add that as an answer rather than just putting closed in the title – user67191 Dec 14 '17 at 6:07
  • 1
    Please note that we do not put "closed" or "solved" tags in question titles. If this question is answered you should write that answer up and accept this answer to mark the question solved. This is also where the solution belongs - not as an edit to the question. Thank you. – Ghanima Dec 14 '17 at 6:49
0

After few days of observing I found that the issue lies with the SD Card. The card seems to be corrupted and many a time soon after booting up, the card fails and hence the Pi stops responding.

This was little tricky as I run the Pi headless and so do not see the issue. I connected the Pi to my TV and for first few trials over few days, it seldom failed. So, the detection took some time.

I tried doing a read from the card to make a clone. But that failed everytime saying there is a hardware related problem. This suggested that the SD card is damaged.

I replaced the SD card and it is working fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.