I've been trying to use Stretch on my raspberry pi 3 for a few weeks already, and it seems that I have some trouble for starting the Pi. I installed Stretch on a 32 Gb SD card, but I also tried with some 8Gb and the result is the same.

The first boot is always great, I have the image on my screen (HDMI to VGA plug). If I use the command reboot, it will reboot perfectly. If I turn it down with the command line shutdown or with the shutdown menu, it won't boot with the image. I can reach the raspberry on SSH, and then reboot it, and the monitor will be on.

I have used Etcher to flash the SD card, and I've tried to download again the image.

Thanks for your help! =)

PS: I know there is already a similar question (Screen won't boot on second startup) BUT there is no answer, not even a hint.

PS2: I have a 2A plug, and it have never been like this with Jessie.

3 Answers 3


This is not strictly an answer, because I frankly don't know, but my observations.

Shutting down the Pi, using any of the halt poweroff or shutdown commands SHOULD do the same thing.

I have occasionally noticed that the display continues to function, indicating that the system has experienced some problems during shutdown. This is only obvious with a connected hdmi screen.

My conclusion is that the videocore (which is independent of the CPU) is continuing to function. As the videocore is responsible for Pi booting this may explain the problems. This view is supported by visible error messages on screen after shutdown.

NOTE my experience, while uncommon, is NOT specific to Stretch, as I have noticed it on earlier releases.

I now always use poweroff on the rare occasions when I need to shutdown one of my Pi and have not experienced this problem recently. I normally only poweroff when performing some "surgery" on the Pi. (Theoretically there should be no difference.)

  • You're maybe right. it could be because of the shutdown command, I will try to take a look at it.
    – Kat_Klinex
    Dec 11, 2017 at 21:47

My raspberry pi 2 had a problem sort of like this. I used an 8GB kingston card. I think that you should either and rewrite the image to it or buy a new SD card that is used in car cameras. These support high read/write speeds.

  • But that's not related to the SD card, I did try 4 of them! Thx for the idea :)
    – Kat_Klinex
    Dec 11, 2017 at 21:47
  • No problem. I am short of SD cards currently as I run different operating systems that have seperate images such as Raspbian, Android and OpenMediaVault. Dec 12, 2017 at 16:19

For now, I fixed it by forcing the HDMI in the config.txt file. It start on a bad resolution, and I need to reboot it to get it back to normal, but at least it works..

Seems that it's related to the HDMI output..

  • Try another HDMI cable? Dec 12, 2017 at 16:17
  • I did try with different cable and screen, doesn't seems to be the problem here.
    – Kat_Klinex
    Dec 13, 2017 at 16:51
  • If everything is ruled out, it might be something to do with the RPi Dec 14, 2017 at 15:46
  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year.
    – Ingo
    Dec 21, 2019 at 1:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.