1

I created a dual-boot setup on my Pi 1B today and have it hooked up to an old NTSC CRT TV. When I first installed the OSes, I pressed "4" on my keyboard to get composite video out, and NOOBS prompted me if I wanted to save this setting. Great. The OSes installed, and I was prompted to pick one to boot into. Everything worked as expected.

Next, I rebooted, but no video out signal through the component port this time. The first OS that NOOBs boots to goes straight to CLI, and I was able to login and reboot (sans monitor), so I know everything is working except for the composite video out.

On the next reboot, I held the Shift key to enter recovery mode, and pressed "4", and voila, I have video again. Selected the OS from the last step, and the video signal goes out again.

So...I know I can force video out through the composite port by editing the config.txt on the booted OS, but can anyone help me with the NOOBS bootloader? I can't find any documentation on the subject; other than I can edit noobs.conf on the SETTINGS partition and use the display_mode setting, but none of the examples tell me what numbers correspond to which video mode (I assume they're the same order as hitting the keyboard in recovery mode, but zero-indexed, so "3" for NTSC?)

Ugh, so frustrating. I'd appreciate any help anyone could give!

Thanks!

  • Duplicate of raspberrypi.stackexchange.com/questions/10073/… – Ameer Dec 12 '17 at 6:45
  • Not a duplicate. That guy's keyboard won't work at all in NOOBs. I can get into recovery mode and switch video modes in it via the keyboard but I don't get composite video until I do that. Additionally, when I pick NTSC (or PAL for that matter), I also get no overscan, so the screen is cropped on my display. Also looking for a fix for that too! – ridgek Dec 13 '17 at 5:42
0

Okay, I sort of figured it out based on issue #142 in the NOOBS github repo:

https://github.com/raspberrypi/noobs/issues/142#issuecomment-29352624

From looking at other sources, it seems the values we're working with are zero-indexed, so presumably,

0 - HDMI
1 - HDMI Safe-mode
2 - Composite PAL
3 - Composite NTSC

Per the official NOOBS guide (https://github.com/raspberrypi/noobs#how-to-change-display-output-modes), it seems that NOOBS first looks at RECOVERY/recovery.cmdline for Recovery Mode's display mode, and a display=x value can be added to the file. However, setting a display value here apparently doesn't work, per issue #175 (https://github.com/raspberrypi/noobs/issues/175). I set mine to display=3, but on boot, I'm not getting the rainbow screen from the GPU check, or the Recovery Mode splash screen which follows through composite, and I assume this is why. (Possibly related to issue #149, too: https://github.com/raspberrypi/noobs/issues/149) Not ideal, but I can live with it.

Next, and, again, working off my own assumptions, the bootloader looks at SETTINGS/noobs.conf, where the setting is display_mode=x. I set mine to a value of display_mode=3. I think NOOBS is supposed to write this to noobs.conf when it initially prompted me to make my display selection permanent, but I opened this file to find a value of display_mode=0. I'm not sure why I was getting no overscan and a cropped picture when selecting the display mode through the keyboard in Recovery Mode earlier, but everything in the bootloader seems to be sized correctly after changing this setting.

Speaking of NOOBS not doing it's job, my config.txt files in each OS were also not correctly set up for component-out. They both had values of hdmi_force_hotplug=1 appended to the end of the files, which is the opposite of what I need.

To sum up, I get no rainbow or Recovery Mode splash screens, but I do get the bootloader's OS selection screen, and that's good enough for me. Hopefully this helps anyone down the road who has this same issue.

  • The biggest mystery is why are you using NOOBS. Are you always booting Raspbian? If yes, then save 1.3GB of wasted SDCard space and switch to plain Raspbian. – Dougie Jan 6 at 10:01
  • Why you posted a needlessly hostile comment on a year-old question that already has an answer is the biggest mystery. I use NOOBS for the bootloader and recovery mode on my multiboot setup. – ridgek Feb 13 at 3:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.