0

Many tries. Many half-fails. All of the package managers that I'm using (apt-get, synaptic) always cannot really finish installations or removals. Just minutes ago I was trying to purge the code::blocks package and IDE, the process didn't complete with multiple dependency errors:

Stuff about missing JDK and JRE

DPKG errors

And yet, I am completely certain that I have not deleted any of these packages, though I have a right to think again, because these problems seem to have started when I ran sudo apt-get autoremove.

Here is the complete output of my failed purging of code::blocks:

pi@raspberrypi:~ $ sudo apt-get purge codeblocks
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  codeblocks-common libcodeblocks0 libwxgtk3.0-0v5
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  codeblocks*
0 upgraded, 0 newly installed, 1 to remove and 1 not upgraded.
12 not fully installed or removed.
After this operation, 6,402 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 195481 files and directories currently installed.)
Removing codeblocks (16.01+dfsg-2) ...
Setting up ca-certificates-java (20170531+nmu1) ...
Error: missing `server' JVM at `/usr/lib/jvm/java-8-openjdk-armhf/jre/lib/arm/server/libjvm.so'.
Please install or use the JRE or JDK that contains these missing components.
dpkg: error processing package ca-certificates-java (--configure):
 subprocess installed post-installation script returned error exit status 4
Processing triggers for mime-support (3.60) ...
Processing triggers for desktop-file-utils (0.23-1) ...
Processing triggers for man-db (2.7.6.1-2) ...
Processing triggers for shared-mime-info (1.8-1) ...
Processing triggers for gnome-menus (3.13.3-9) ...
dpkg: dependency problems prevent configuration of openjdk-8-jre-headless:armhf:
 openjdk-8-jre-headless:armhf depends on ca-certificates-java; however:
  Package ca-certificates-java is not configured yet.

dpkg: error processing package openjdk-8-jre-headless:armhf (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of openjdk-8-jdk-headless:armhf:
 openjdk-8-jdk-headless:armhf depends on openjdk-8-jre-headless (= 8u151-b12-1~deb9u1); however:
  Package openjdk-8-jre-headless:armhf is not configured yet.

dpkg: error processing package openjdk-8-jdk-headless:armhf (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of openjdk-8-jdk:armhf:
 openjdk-8-jdk:armhf depends on openjdk-8-jdk-headless (= 8u151-b12-1~deb9u1); however:
  Package openjdk-8-jdk-headless:armhf is not configured yet.

dpkg: error processing package openjdk-8-jdk:armhf (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of openjdk-8-jre:armhf:
 openjdk-8-jre:armhf depends on openjdk-8-jre-headless (= 8u151-b12-1~deb9u1); however:
  Package openjdk-8-jre-headless:armhf is not configured yet.

dpkg: error processing package openjdk-8-jre:armhf (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of default-jdk:
 default-jdk depends on openjdk-8-jdk; however:
  Package openjdk-8-jdk:armhf is not configured yet.

dpkg: error processing package default-jdk (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of default-jre-headless:
 default-jre-headless depends on openjdk-8-jre-headless; however:
  Package openjdk-8-jre-headless:armhf is not configured yet.

dpkg: error processing package default-jre-headless (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of default-jdk-headless:
 default-jdk-headless depends on default-jre-headless (= 2:1.8-58+b2); however:
  Package default-jre-headless is not configured yet.
 default-jdk-headless depends on openjdk-8-jdk-headless; however:
  Package openjdk-8-jdk-headless:armhf is not configured yet.

dpkg: error processing package default-jdk-headless (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of icedtea-netx:armhf:
 icedtea-netx:armhf depends on openjdk-8-jre; however:
  Package openjdk-8-jre:armhf is not configured yet.

dpkg: error processing package icedtea-netx:armhf (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of icedtea-8-plugin:armhf:
 icedtea-8-plugin:armhf depends on openjdk-8-jre; however:
  Package openjdk-8-jre:armhf is not configured yet.
 icedtea-8-plugin:armhf depends on icedtea-netx (= 1.6.2-3.1); however:
  Package icedtea-netx:armhf is not configured yet.

dpkg: error processing package icedtea-8-plugin:armhf (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of default-jre:
 default-jre depends on default-jre-headless (= 2:1.8-58+b2); however:
  Package default-jre-headless is not configured yet.
 default-jre depends on openjdk-8-jre; however:
  Package openjdk-8-jre:armhf is not configured yet.

dpkg: error processing package default-jre (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of default-java-plugin:
 default-java-plugin depends on default-jre (= 2:1.8-58+b2); however:
  Package default-jre is not configured yet.
 default-java-plugin depends on icedtea-8-plugin; however:
  Package icedtea-8-plugin:armhf is not configured yet.

dpkg: error processing package default-java-plugin (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 ca-certificates-java
 openjdk-8-jre-headless:armhf
 openjdk-8-jdk-headless:armhf
 openjdk-8-jdk:armhf
 openjdk-8-jre:armhf
 default-jdk
 default-jre-headless
 default-jdk-headless
 icedtea-netx:armhf
 icedtea-8-plugin:armhf
 default-jre
 default-java-plugin
E: Sub-process /usr/bin/dpkg returned an error code (1)

So what exactly am I supposed to do to fix these problems? I have tried running sudo apt-get install default-jdk but apt-get said that the package didn't exist.

How do I fix these dependencies then?

How do you "configure" the packages?

Thank you.

1

The repo may not have the most up-to-date version of jdk or may be broken somehow. Check out this link and download that tells you how to download and install jdk 8 for raspberry pi.

Here is a post from the Raspberry Pi forum that has some additional info on adding some symbolic links.

-1

Try sudo apt-get -f install

If you are always having problems you are probably always doing something wrong. Are you downloading packages from non-standard or non-Raspbian repositories?

  • I am downloading packages from standard package repositories. Is Code::Blocks a non-standard package? This problem has been going on for all package and remove operations. – iostreamerX Dec 13 '17 at 0:01
  • Oh, btw, your command of 'sudo apt-get -f install' didn't work. It didn't fix any of my DPKG problems – iostreamerX Dec 13 '17 at 0:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.