So I installed Raspbian Jessie onto my Raspberry Pi 3 because I want to use RetroPie and Stretch doesn't support it yet. I installed Raspbian just fine, it boots and works as expected.

After that I went on to manually install RetroPie, and since that the following happens:

  1. Raspbian boots into desktop - tty7, great.
  2. Maybe 5 seconds after this, it automatically reverts to tty1 and I have to Ctrl + Alt + F7 back into desktop mode.

So far I have tried the following:

  1. I have run raspi-config and within boot options have set it so it boots into Desktop without password, however this doesn't work.
  2. I have run retropie_setup.sh and set the boot option to boot into desktop mode, this does not work.
  3. Similarly, I have set emulationstation to run on boot, which works fine but then if I close out of emulation station, xserver is not running and I have to run startx to get a GUI.

Has anybody got any other ideas I can try please?

Thank you.


1 Answer 1


Solution: edit the splashscreen shell script using

sudo sed -i 's/fbi -T 2/fbi -T 1/g' /opt/retropie/supplementary/splashscreen/asplashscreen.sh

You might have to do that again after updating RetroPie using retropie_setup.sh (I had to).

Background info: https://retropie.org.uk/forum/topic/10034/display-switch-from-pixel-to-tty1-after-manual-installation

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.