I finally got it working that I can use a Huawei E173 modem on my raspberry. When activating it with

sudo ifup 3gModem

everything works fine, and it connects itself to my Server as I can see it in the log files. But when I try to connect to the modem IP via port 22 it won't work. Same with apache. I installed an apache server on it. And when i call the raspberrys IP over the wlan0 interface I can access is, with the ppp0 interface it completly blocks everything that goes into the pi. Not even pinging is possible. Do you know any solutions to this? I tried googling for sometime but nothing useful came up

  • 2
    Reverse SSH is the way! You would find a lot of issues trying to setup ssh through mobile network, reverse ssh will make it much simplier. Dec 14, 2017 at 10:13
  • do you know any good tutorials for reverse ssh with windows and raspbian? Dec 14, 2017 at 10:15
  • No sorry i. I'll draft up an answer with the basics of what you need to do, and from there you should be able to do the setup pretty easily with some more googling. Dec 14, 2017 at 14:12
  • well I already did that but sorry for asking Dec 14, 2017 at 14:42
  • well i guess no help must be better than some help for you. Dec 14, 2017 at 15:02

1 Answer 1


you may need to enable SSH in raspi-config. you can also try reinstalling openSSH-server with

sudo apt-get remove --purge openssh-server
sudo apt-get install openssh-server

you may also need to set up port forwarding on your gateway as well. this would be a network configuration problem and not a RPi problem.

  • ssh is enabled, I reinstalled it and I don't quite have access to my gateway. I mean it's directly within the providers network. Do you think maybe reverse SSH or a VPN connection could help me solve this? Dec 13, 2017 at 21:19
  • 1
    i think if you cannot configure the device to forward port 22 (or a port in general for SSH) you will never be able to get it to work with SSH. I believe VPN still requires port forwarding in addition to some other IP protocols. Dec 13, 2017 at 22:21
  • well it can't be impossible Dec 14, 2017 at 5:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.