2

I just setup Raspbmc on my Raspberry PI which I am using as HTPC. I had installed Raspbian and custom built XBMC earlier and it served the purpose. I liked Raspbmc for its unified packaging and thought it to be better than custom setup.

However, I am facing a problem playing HD Videos (i.e. 720p / 1080p) where the videos do not occupy the full screen of the TV; instead, the picture is bounded by black bars on the top and bottom.

For 4:3 videos, I have configured wide zoom on Raspbmc and they are shown full screen, but I couldn't find any such setting for 16:9 inputs.

How do I get Raspbmc to not letterbox 16:9 content?

2

Go to Settings > System > Video output > Video calibration (the last option):

http://i.stack.imgur.com/eKxDM.png

There you can resize the screen and set the correct aspect ratio.

Please go through all comments for more details.

7
  • Thanks for advice. I had already setup the callibration by setting cyan arrows to top-left and bottom-right corner and also adjusted the pixel ratio but with no luck ! If I stretch screen (by not putting arrows in right place), the entire XBMC interface gets skewed.
    – jatanp
    May 27 '13 at 16:45
  • Are you sure the videos are not being displayed like that in order to keep the aspect ratio? is there a black boarder around all the screen? Or only two horizontal or vertical lines?
    – GuySoft
    May 27 '13 at 16:50
  • There are only two horizontal lines in top & bottom. I tried with many 1080p videos from YouTube and same result.
    – jatanp
    May 27 '13 at 17:49
  • Ok two lines indicate that the overscaning is not the problem, its the aspect ratio. Did you set the cyan rectangle at the center of the video calibration to be a box (using ruler or long object against the screen helps)? That might be the solution. Either that or you physical screen is not 16:9. You are connected by the HDMI port right?
    – GuySoft
    May 27 '13 at 17:57
  • 1
    Hi GuySoft, It looks like we are on right track. I adjusted the pixel ratio and it stopped the adjustment as soon as it reached 1.125, however the rectangle is not perfect square yet ! But the width of bars are definitely gone down. Please let me know whether the ratio can go beyond 1.125 ! Also I really appreciate if you can explain and point me to article which would explain this stuff.
    – jatanp
    May 27 '13 at 19:20
0

There's an option in raspi-config for configuring overscan - I would start there and see if that lets you eliminate the black bars.

1
  • Thanks Dermot, I changed the setting but that did not help.
    – jatanp
    May 27 '13 at 16:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.