0

I just installed NOOBS onto the SD card but I have just messed it up, it wasn't right for me anyway since I needed php5, and the latest NOOBS comes with php7. How can I install NOOBS so that I can install php5?

3
  • 1
    PHP5 is only receiving security updates. Why do you need php7 and why won't the newer version work? Dec 15 '17 at 0:04
  • @SteveRobillard I am currently at Uni and the Pis are part of a project. We are required to use Php5 and not any other version.
    – 15150776
    Dec 15 '17 at 0:09
  • Tell your professor that PHP5 is quickly going the way of the dodo and PHP7 is what industry will be expecting you to know... Dec 15 '17 at 0:43
2

If you really need php5, add the jessie to your /etc/apt/sources.list

$ sudo -s

# echo "deb http://mirrordirector.raspbian.org/raspbian/ jessie main" >> /etc/apt/sources.list

and then

# apt-get update && apt-get install php5

However, you should be advised that php5 is old news.

2

NOOBS will only install the latest Raspbian, if you need an obsolete version you will need to install Raspbian, which you can find on https://downloads.raspberrypi.org/raspbian/images/

You might get away with an old NOOBS from https://downloads.raspberrypi.org/NOOBS/archive/

Mind you PHP7 has been the standard release on most distributions for 2 years; it is only Debian which has not changed until recently.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.