1

I followed the instructions here. The pi boots and shows up in my wifi router with an address.

$ ssh -vvv pi@192.168.2.65
OpenSSH_7.4p1, LibreSSL 2.5.0
debug1: Reading configuration data /Users/bill/.ssh/config
debug1: /Users/duane/.ssh/config line 90: Applying options for *
debug1: Reading configuration data /etc/ssh/ssh_config
debug2: resolving "192.168.2.65" port 22
debug2: ssh_connect_direct: needpriv 0
debug1: Connecting to 192.168.2.65 [192.168.2.65] port 22.
debug1: connect to address 192.168.2.65 port 22: Operation timed out
ssh: connect to host 192.168.2.65 port 22: Operation timed out

I am using a Raspberry Pi 3 Model B. This is consistent with the two Pi's that I have. Both behave the same way.

I am using the built-in wifi.

As soon as I plug in Ethernet, the connection starts working. However, all of the network traffic is through Ethernet not Wifi. If I unplug Ethernet, the connection is hung (doesn't disconnect). Plugging back in the Ethernet resumes the connection. This is expected, but further demonstrates that wifi is not working.

My application for the Raspberry Pi needs Wifi to work alone. I also need to be able to plug in Ethernet and have that work as well. But wifi must work alone. No Ethernet.

What is the magic setup that causes the Raspberry Pi to work with Wifi alone?

Other items of note:

  • I am using Raspbian Stretch Lite, November 2017, 2017-11-29, 4.9
  • I have also tried using 2017-07-05-raspbian-jessie-lite.zip with the same results

Is this just not a supported configuration? Is the built-in wifi supposed to work?

Thank you for your help!

  • 1
    Using only wifi is absolutely a supported configuration. What steps have you done to configure wifi? Based on the "Operation timed out", it seems ssh is not finding your RPi at 192.168.2.65. Try ssh -vvv pi@raspberrypi.local. Have you verified that your RPi has a wifi connection? Also, verify your wifi access point (router) allows wifi-wifi connections if that applies. – bobstro Dec 21 '17 at 5:05
  • pi@raspberrpi.local does not resolve. (I'm on a Mac with Sierra.) ssh is finding the port but the connection times out. As soon as I plugin the Ethernet, the exact same command works properly. – Bill Door Dec 21 '17 at 5:19
  • @bobstro I think you have it! I'm connecting to my Guest wifi network. No internal routing allowed. I'll try my internal network. – Bill Door Dec 21 '17 at 5:24
  • I've set up a dozen RPis on raspbian jessie and stretch, and don't have this problem. Once I have ssh configured, it works seamlessly between wired and wifi. Did you do anything to set up a firewall setup or ssh configuration, or just defaults? Is the computer you're connecting from (the Mac) on wifi as well? Can it connect to other machines over wifi? [edit: Looks like you've got it. Security settings work!] – bobstro Dec 21 '17 at 5:25
  • @bobstro, I've added the solution. You hit on it exactly. wifi-to-wifi routing is disabled in the guest network. Using Ethernet allowed the connection. Using the internal wifi network fixed the problem. – Bill Door Dec 21 '17 at 5:34
2

Operator error. Embarrassing.

I configured the Raspberry Pi using the AP Guest network. The Guest network does not allow internal Wifi routing.

Switching to the internal "secure" wifi network works fine.

Thank you for the help to get me to realize the problem.

@bobstro, I owe you a few creds.

  • Glad you got it going. This one can be tricky because both devices "work" (can get to the Internet) and might work from a wired connection. I've run into it myself, so I'm just passing the info on. At least you're in control of the wifi network! – bobstro Dec 21 '17 at 5:58
0

I had similar issue - did you copy the wpa_supplicant.conf from the website? If so, check your quotes - mine were matching quotes, not the straight up/down type. Changed those and the WiFi config worked.

  • I typed the file myself. The quotes are correct. If the quotes were incorrect, I would not connect to the Wifi Router. I am connected to the network. The device is assigned an address. The connection will not work without Ethernet plugged in. Thanks. – Bill Door Dec 21 '17 at 4:50
  • and you put the ssh.txt or ssh file there too? – Alan McDonley Dec 21 '17 at 5:01
  • ssh only (not ssh.txt). Yes. As soon as I plugin Ethernet everything works. Even over the address given to the wifi adapter (although the traffic is being routed over the Ethernet connection.) – Bill Door Dec 21 '17 at 5:03
  • could you post the ifconfig / iwconfig while you have the eth0 connected - maybe a hint there? – Alan McDonley Dec 21 '17 at 5:10
  • Another user reported similar issue: superuser.com/questions/1089483/… AP Isolation setting in router – Alan McDonley Dec 21 '17 at 5:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.