0

Helllo! I have been working with pi zero for a few months now and suddenly I cannot boot and I am getting the following message: Error

After researching online I came to the conclusion the SD was corrupted (not the power supply) When I connect the SD to my raspberri pi usb port (with micro-to-usb adpter) I can tell that only two partitions load up: "boot" and "root" but no "settings" - at first root was unlabeled so I labeled it. But it seems I can see all of my files.

Goal: I lost my backup so I have to get this PiZero to run with this SD or I will have to reinstall all the six months worth of libraries and recreate all of the setting which I don't know how to do... It will be fine too if I cold have copied those somehow to a new SD

Most important things I have tried:

  • Put the SD in a different pi Zero - Result: Same problem

  • Create new clean SD with Noobs - worked fine so the problem isn't the pi-zero

  • Run "fsck" on the SD and it seemed to fix some things but I still get the same error on boot

  • Copy the root partition contents of my SD to the clean working SD - Boot error: "kernel panic - not syncing attempted to kill init"

  • Copy the boot partition contents of the working SD into my SD - kernel panic error while booting

I am desperate at this point and your help will help me a lot! Thank you!

*Edit: Just to be clear - I think I can read my old files (from the root partition) but still its not possible to boot

  • What kind of libraries and settings do you want to recover? – Mark Dec 21 '17 at 14:13
  • I'd try to boot from the clean working SD and connect an SD card reader via the USB port with the faulty SD card. If you can mount the device from there (probably via sudo mount /dev/sdb2 /mnt, but check dmesg/fdisk -l), you might be able to recover the data. – steviethecat Dec 21 '17 at 19:06
  • The libraries and setting I was talking about are used to control motors of a robot using Pi-zero... I used it because of its size so I cant have an external USB connected to it as a permanent fix even if it would work – Daniel Kuv Dec 21 '17 at 22:29
  • Yeah that mmcblk0 could be a hardware issue with the SD card, and many of us can relate not wanting to wait on long apt-get runs again. To clarify, have you tried copying contents of both the boot and root partitions onto a working card? If you were to copy only one or the other it likely won't work because boot/kernel7.img won't match the kernel version in /root/lib/modules (being 6 months old). – jdonald Dec 22 '17 at 18:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.