i am finding difficulties with my pi not starting up with desktop screen, is it a simple issue or do i need an update (i am connected to wifi) top image is controller i am using, second is screen upon startupenter image description here

enter image description here

  • What OS are you using. If it's RetroPie you don't get a desktop. Dec 22, 2017 at 10:45
  • oh i think it is retropie, thanks that helps me not waste my time trying to figure it out Dec 22, 2017 at 11:08
  • If you want the desktop, you can install RetroPie onto Raspbian. There's a guide on the RetroPie website. The RetroPie image (which you maybe using) is supposed to work more like an appliance and boot straight to Emulation Station. Dec 22, 2017 at 11:23
  • @mintyfreshpenguin RetroPie IS Rasbpian. It's a collection of packages installed on top of Raspbian.
    – Nilpo
    Apr 29, 2018 at 19:27

2 Answers 2


You can install the LXDE desktop on your RetroPie image:


If you want to boot directly to your desktop, go to "RetroPie configuration" (in EmulationStation) and select "raspi-config" and change the boot behavior to desktop (Enable Boot to Desktop/Scratch):



Just to clarify a bit, RetroPie is a collection of packages installed on top of Raspbian. There is no need to manually install RetroPie on top of a clean Raspbian image in order to have a "desktop". From RetroPie, you can go to the command line and install any desktop environment that you choose. If you want to replicate a vanilla Raspbian experience, you just need to install the raspberry-ui-mods package.

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install --no-install-recommends xserver-xorg
sudo apt-get install raspberrypi-ui-mods

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.