0

I have huge problems getting the snes9x emulator to run on a Raspberry Pi 3b with the Debian 9 (Stretch) + Pixel desktop.

It all boils down to libjpeg8 (libjpeg.so.8 library) missing. This library doesn't seem to exist on the latest Debian release.

Does anybody know a workaround?

1

Try:

sudo apt update
sudo apt install libjpeg8

If you're attempting to run an existing snes9x binary on Stretch, once you have all dependencies it will typically work as long as you haven't enabled the full OpenGL driver. However if building from source, take heed of notes in this thread.

  • libjpeg8 is no longer in the stretch repo due to a move to the libjpeg turbo library. – Dennis Bauszus Dec 25 '17 at 11:09
  • 1
    It's not installed by default, but it should be possible to install libjpeg62-turbo, libjpeg8, and even libjpeg7 + libjpeg9 altogether. In fact I just tested this on my Stretch system. I've edited my response to include a sudo apt update step just in case. If the problem persists, could you edit your question to provide the output of apt-cache search libjpeg, or the output of sudo apt install libjpeg8 in case it's a conflicting package issue? – jdonald Dec 25 '17 at 17:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.