0

When I restart my router I can't connect to my Pi(3) anymore via IPv4 (IPv6 works!) until I restart the Pi (I've tried connection with SSH, SFTP, DHCP, HTTP(S) and the ping command). It is connected directly to the router via ethernet. I've tried to connect to it from multiple points: Computer (directly connected to the router via ethernet) and Mobile phone (WLAN). The internal router settings show the pi as connected. Any help and ideas are appreciated. The Pi has set a static IPv4 address to 192.168.2.97.

Additinal Info: I tried some commands while on State 3 (.99 is my pc):

root@raspberrypi:~# ping 192.168.2.99
connect: Network is unreachable
root@raspberrypi:~# ping 8.8.8.8
connect: Network is unreachable
root@raspberrypi:~# ping google.de
ping: google.de: Temporary failure in name resolution

Some pictures to illustrate my problem:

Start. Everything works. (State 1)

1 (Start) - State 1

Router goes offline. (State 2)

2 (Router down) - State 2

Starting router back again. IPv4 doesn't work. (State 3)

3 (Router up again) - State 3

Restarting Pi. (State 4)

4 (Restarting Pi) - State 4

Pi has restarted, everything works again. (State 5)

5 (End, back to start) - State 5

2
  • Check to make sure another device hasn't been issued 192.168.2.97 after the router restarts.
    – JanuskaE
    Dec 24, 2017 at 2:35
  • @JanuskaE The Pi (via Ethernet) is the only device with .97. Even the WLAN interface has another IP. The DHCP Range (set by PiHole on the same Pi) goes from .201 to .254. Also: my pc I tried accessing the Pi from also has a static ip (.99). Dec 24, 2017 at 12:18

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.