3

I use my HDMI slot every time I plug my Raspberry Pi in.

But I plugged it in the other day, and my monitor just said No Signal.

So I plugged it in via Video, and it works. I just don't want to use it though, becuase it's bad quality and it so annoying to change the source every time as it's set automatically to HDMI.

So how do I get back to HD?

Thanks.

  • was the HDMI display connected and powered on when the Pi started up? If not it will disable the HDMI port assuming it isn't needed. you can set it to force on in config.txt as well as specify the display configuration with an edid.dat file you generate from the tvservice utility if it will be a common occurrence that the Pi comes up with the display not powered on or connected. – JoshHetland May 30 '13 at 5:22
  • @JoshHetland - No. I started it up with it in. No Signal. – horIzoN May 30 '13 at 8:11
  • Was the tv on when the Pi booted? – Thorbjørn Ravn Andersen Oct 8 '13 at 15:24
6

If you know you won't be using the composite output, you can set up the pi to always use the hdmi output, even when no device has been detected. That way it will pick up the screen when it's attached, even if done at a later stage.

In your config.txt add/change the following line:

hdmi_force_hotplug=1

For more (screen and other) settings, see http://elinux.org/RPiconfig

0

With my Pi I noticed: If the display is off when you start the Pi then the screen stays blank. If the display is started before the pi it works fine.

  • The thing is, I do that. I don't know what's happening. – horIzoN May 30 '13 at 9:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.