I have bought a Pi and am a little clueless what to do in order to start working on it. I bought a starter kit with a sd-card (NOOBS Software on it). Shouldn't it be possible, to put the micro-sd in the Pi, plug in the power-cable and access the Pi via ssh (headless)?

I read, that ssh must be actived in some cases before. But when I plug in the sd-card in my PC I see something like this:

I created an empty file "ssh" (no file extensions) to activate ssh, as can be seen.

However, whenever I type ssh [email protected], on my Ubuntu Terminal on the Home PC, I get Permission denied, please try again. The password I type is raspberry.

Shouldn't everything be set correctly already?

The starter kit is from: https://www.amazon.de/Raspberry-Pi-3-Wert-Starter-Kit/dp/B01M3VQBK1/ref=sr_1_sc_2?ie=UTF8&qid=1514482690&sr=8-2-spell

I think, I have to change the SD-card somehow.. But I am not sure how..

My home PC has Ubuntu 16.04.

Thanks everyone!


Hello again!

Thank you all for your help. I briefly want to share, what I have done so far.

I have installed Raspbian as OS on the sd-card now. It worked. Then I have added an empty ssh file (no file extension) in order to enable ssh service on the Pi. Then I created a wpa_supplicant.conf file, which contains my wifi information. It lookes like this:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev update_config=1 country=AU network={ ssid="Your WiFi SSID" psk="Your WiFi password" key_mgmt=WPA-PSK }

Both, ssh file and wpa_supplicant.conf file are in the boot partition of the sd-card now.

However, ssh connection is still not possible... I still get the permission denied message.

I made some changes in the config.txt and the cmdline.txt file as suggested in this tutorial: https://www.mickmake.com/archives/2777. But it still doesn't work.

I also set a rule in the Ubuntu firewall to allow ssh: sudo ufw allow 22/tcp. That didn't help either.

Another thing, that confuses me is, that the ssh file and the wpa_supplicant.conf seem to have dissapeared after I take the sd-card out of my laptop.

I also tried to check the default password on /etc/passwd, however, I can't find it in there:

root:x:0:0:root:/root:/bin/bash daemon:x:1:1:daemon:/usr/sbin:/usr/sbin/nologin bin:x:2:2:bin:/bin:/usr/sbin/nologin sys:x:3:3:sys:/dev:/usr/sbin/nologin sync:x:4:65534:sync:/bin:/bin/sync games:x:5:60:games:/usr/games:/usr/sbin/nologin man:x:6:12:man:/var/cache/man:/usr/sbin/nologin lp:x:7:7:lp:/var/spool/lpd:/usr/sbin/nologin mail:x:8:8:mail:/var/mail:/usr/sbin/nologin news:x:9:9:news:/var/spool/news:/usr/sbin/nologin uucp:x:10:10:uucp:/var/spool/uucp:/usr/sbin/nologin proxy:x:13:13:proxy:/bin:/usr/sbin/nologin www-data:x:33:33:www-data:/var/www:/usr/sbin/nologin backup:x:34:34:backup:/var/backups:/usr/sbin/nologin list:x:38:38:Mailing List Manager:/var/list:/usr/sbin/nologin irc:x:39:39:ircd:/var/run/ircd:/usr/sbin/nologin gnats:x:41:41:Gnats Bug-Reporting System (admin):/var/lib/gnats:/usr/sbin/nologin nobody:x:65534:65534:nobody:/nonexistent:/usr/sbin/nologin systemd-timesync:x:100:103:systemd Time Synchronization,,,:/run/systemd:/bin/false systemd-network:x:101:104:systemd Network Management,,,:/run/systemd/netif:/bin/false systemd-resolve:x:102:105:systemd Resolver,,,:/run/systemd/resolve:/bin/false systemd-bus-proxy:x:103:106:systemd Bus Proxy,,,:/run/systemd:/bin/false pi:x:1000:1000:,,,:/home/pi:/bin/bash messagebus:x:104:109::/var/run/dbus:/bin/false avahi:x:105:110:Avahi mDNS daemon,,,:/var/run/avahi-daemon:/bin/false ntp:x:106:111::/home/ntp:/bin/false sshd:x:107:65534::/var/run/sshd:/usr/sbin/nologin statd:x:108:65534::/var/lib/nfs:/bin/false lightdm:x:109:114:Light Display Manager:/var/lib/lightdm:/bin/false pulse:x:110:116:PulseAudio daemon,,,:/var/run/pulse:/bin/false rtkit:x:111:118:RealtimeKit,,,:/proc:/bin/false

I currently have no ideas, what the problem could be.


3 Answers 3


NOOBS is an operating system install manager, not an operating system. If you haven't selected an operating system to install via NOOBS, you cannot use SSH to remotely connect to your raspberry pi.

If you intend to use Raspbian, I recommend flashing Raspbian directly to an SD card.

Next, you will still need to add the ssh file to the SD card once flashed in order to enable SSH on Raspbian.

  • Hello and welcome! This answer raspberrypi.stackexchange.com/a/67353/19949 claims different. Did you test it or have some references?
    – Ghanima
    Dec 28, 2017 at 21:08
  • @Ghanima That link states "run by noobs at end of rasbian install" - you still need a keyboard for initial setup.
    – Milliways
    Dec 28, 2017 at 23:57
  • @Milliways fair enough, but that requires prior knowledge of how noobs works, from the answer alone one cannot derive this. As always we seem to come to the conclusion that noobs in fact overcomplicates things and people would be better of using just Raspbian.
    – Ghanima
    Dec 29, 2017 at 9:41

You NEED a keyboard and screen to setup NOOBS. See https://www.raspberrypi.org/learning/software-guide/

Unless you intend to run multiple OS from the card, just download Raspbian.


U can install the latest ArchLinuxARM. The installation can be done from an host PC with SD Card Reader.

After the installation u will be able to connect remotely via SSH


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.