3

I have a RPi 3 and a 7" touch screen, powered by a MW GS18E05 adapter. It says output 5-6V, 3.0-2.5A, max 15W.

The top right corner yellow flash low power warning shows up when I boot and then it comes and goes when the machine is running. I have some graphical interface, not sure which one. It is a standard Raspbian distribution I believe. I am not doing anything else, no applications running.

Am wondering what this means? Is it normal for the flash icon to appear?

Do I need a better power supply?

Addition: the power is connected to the screen, and then there are cables from it to the GPIO (they came with the screen).

More: am using a short custom made cable from a panel mount barrel type connector to micro usb.

Also: when I measure voltage it says 5.12 on the adapter (not connected to anything) and between 4.96 and 5.02 on the connector with the RPi running. The flash icon comes and goes and is not on for more than a few seconds at a time. I wasn't able to notice any correlation with the voltage fluctuations.

3

Either the power supply OR the cable is inadequate. (I make my own cables, because there is no source of adequate cables.)

See Raspberry Pi Power Limitations

0

The warning is telling you the power supply is insufficient, in particular it is dropping below 4.65V under load.

  • This is due to not enough current? – Wilf Jan 10 '18 at 15:56
  • 1
    @Wilf The power supply is insufficient. It can't supply the current required so the voltage drops. – joan Jan 10 '18 at 15:59
0

The power is insufficient in the respect the power supply cannot supply enough current

I've had this issue running just a Pi 3 from a 1.8A 5V USB adapter. A 2.5A solved the issue for me. Look for higher current, NOT higher voltage*.

With regards to measuring with the voltmeter, it may be difficult to see the spikes that cause the symbol to appear, most likely when under load. You can try measuring how much current draw the Pi is using (perhaps compare this with and without the touchscreen) to see how much extra the screen uses, though a quick look at retailers suggest supplys that can do 2.4A may be enough - so a 3A supply should work...

*A slightly higher voltage (e.g. 5.1 on some semi-official adapters) will help with voltage drop over the cable length etc

  • The power supply is rated 2.5-3A, so should work. I have not been able to find out how much the touchscreen needs/wants. I do not have any easy way to measure the current. Also, I am using a custom cable, so that might be a problem, I suppose. – Tomas By Jan 10 '18 at 16:09
  • That's probably (part of) the issue (how long is it, and/or what resistance does it have). A additional factor on the 2A supply I had is that it was using a 2-3 meter long cable (note: USB spec is 2 meter cable)! 2.5A & 2A as far as I remember were similar voltages to start of with. EDIT: if its the stock cable on the supply with a small extension for power the PI it, again, should of been fine... – Wilf Jan 10 '18 at 16:14
  • 1
    The custom cable I have is about 15cm. It does not have any measurable resistance according to my multimeter, on the outer wire. I was not able to measure on the inner one. – Tomas By Jan 10 '18 at 16:40
  • @TomasBy ok. if you find a actual reason/solution for this, post the answer ;) – Wilf Jan 10 '18 at 20:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.