2

Since a while (approx. 1 month) now midori is not starting anymore and gets a segmentation fault. Yesterday I updated the firmware and software to the latest versions, still no change. I also tried to remove and reinstall it with purge.

I also compiled https://code.google.com/p/minimal-web-browser/ with the same result on that browser. It might be a webkit problem. I know there was also an issue one year ago, but it should be resolved by now.

I have no idea what else to do.

EDIT

I removed all Webkit packages that I found and installed midori again and now it works.

  • is there anymore information/detail on the error other than segmentation fault? stack trace or log file? – kolin May 30 '13 at 9:37
  • it just prints: zsh: segmentation fault midori, I didn't find out if and where midori stores logs. – Matthias Tylkowski May 30 '13 at 9:45
1
+50

Midori is under heavy development, and it looks like this is just a bug related to improper handling of memory. I would compile the latest git daily with a cron script to make sure you get a version that doesn't contain that bug as soon as it comes out.

  1. Create a script to update Midori daily. Add these lines to it:

    sudo git clone git://git.xfce.org/kalikiana/midori
    cd midori/
    sudo ./configure --prefix=/usr && make
    sudo checkinstall
    cd ../
    sudo rm -rf midori/
    
  2. To edit your crontab file, type the following command at the UNIX / Linux shell prompt:

    $ crontab -e
    
  3. Add your script to the list. Be wary of the syntax that cron follows. Here is an easy to remember format:

    * * * * * command to be executed
    - - - - -
    | | | | |
    | | | | ----- Day of week (0 - 7) (Sunday=0 or 7)
    | | | ------- Month (1 - 12)
    | | --------- Day of month (1 - 31)
    | ----------- Hour (0 - 23)
    ------------- Minute (0 - 59)
    

    So, to update Midori five minutes after midnight, every day, enter:

    5 0 * * * /path/to/script.sh
    
  • I use Kweb now, so I can not confirm what you are saying. What I could find out and also added in my edit was that the problem should be related to some webkit libraries that get corrupted for unknown reasons on the pi. – Matthias Tylkowski Dec 18 '13 at 9:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.