3

I know at first glance that this question has been asked many times, but I have seen no one with the same problem as me so far. I also was really excited to start using my raspberry pi 3 model B v1.2 but have been stuck on this for the past week and am desperate for a solution.

My first attempt was to image the Raspbian download straight on to the SD. To do this I first overwrite formatted my sd using SD Card Formatter. Next I used win32imager to put the image on the sd card. Upon booting the raspberry pi, the LED did a weird combination and then both turned off, on screen it gave me an error:

"Kernel panic-not syncing: VFS: unable to mount root fs on unknown-block(179,2)"

My for my second attempt I did the same format and unzipped the NOOBS os on to the sd, when I tried booting, literally nothing happened. Only the power LED was on. I've repeated these steps, tried solutions to other "similar" questions but nothing has worked!

Since the first step actually gave me on screen output, I'm assuming that my SD card is not the problem, but my debugging skills are limited and that's the only assumption I could make.

Any input would be appreciated.

  • It's probably your SD Card try a different one – Bra1n Dec 30 '17 at 19:54
1

It looks like the first process you followed should have worked just fine, as for the second one, just unzipping NOOBS into the SD card will not give you a bootable OS image.

I’ve never used Win32DiskImagerSD (I have a Linux machine and just image the cards from the command line using the dd utility), but since that tool is linked to on the raspbian site, you can surely trust that it’s doing its job.

So my guess is that your SD card is the culprit. To be fair, SD cards are easily corrupted if you don’t handle them well, and sometimes even if you do. I’ve had RPis working well for months and all of a sudden they become corrupted, usually is because they shutdown due to a power cut or something like that. If you have another one around, I’d just try imaging it with Win32DISD. Or else, just try it again with the same SD card (format it first). Sometimes it takes a few tries.

  • Okay, I will go pick one up and give it another try. If not handled well, could the raspberry pi's sd reader (not sure what it's called) be corrupted just as easily? – Smeboo Dec 30 '17 at 22:22
  • @Smeboo Not at all, don’t worry about it. The Pi’s hardware/firmware is pretty solid, so it’s very unlikely that your problem is there. – eviesca Dec 30 '17 at 22:27
  • 1
    Awesome! well turns out you were right about the SD! Ended up being the culprit. Found that weird though because of the fact that it was able to give me an error on screen! Thank you very much! – Smeboo Dec 31 '17 at 1:58
1

The first step you SHOULD always check after downloading is to verify the checksum.

The error suggests the image is incomplete. This may be due to a download error OR imaging program limitation.

Recent versions of Raspbian are packaged differently, and the images do NOT have 4MB blocks. This caused many imaging programs to write incomplete images, as they did not write the last, incomplete, block.

I don't know if win32imager has this problem, but it definitely works using the Foundation recommended imager Etcher which writes incomplete blocks.

PS When writing an image there is NO NEED to format - the image will replace anything on the card, including the partitioning.

  • This may have been it but I went and picked up a new SD and the NOOBS installation worked! Thank you for your input! – Smeboo Dec 31 '17 at 1:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.