3

It appears the wifi is working, and the device can see my SSID. However when it connects it gets an error:

CTRL-EVENT-ASSOC-REJECT status_code=16

I checked my router and the 2.5 GHz network settings. I have seen many posts with similar issues and none seem to have the resolution I need. I did a full apt update/upgrade and rebooted several times.

How do I troubleshoot this issue and get the wifi working?

1
  • Never have I felt so close to another soul... and yet so helplessly alone – NieDzejkob Dec 23 '18 at 10:22
0

I encountered the same problem with a Raspberry Pi 4B. In my case, it was related to the fast roaming feature. To temporarily disable it for the Broadcom WiFi driver, run the following two commands:

rmmod brcmfmac
modprobe brcmfmac roamoff=1

Afterwards, try to connect to your access point again:

wpa_supplicant -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf

If the connection was successful, you can persist the roamoff setting by creating /etc/modprobe.d/brcmfmac.conf with the following content:

options brcmfmac roamoff=1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.