I have a small problem: I want to use pin 13 [GPIO 27]. (pin 13 [GPIO 27] should output 3.3V)

I tried [in Shell (Putty)]:

gpio mode 13 out
gpio write 13 1

but nothing happened.

I also tried pin 40 and other pins, but it doesn't work. But with pin 7 it works.

Is my pi broken? Or what is the problem.

Many Thanks!

  • Er? What did you expect to happen? – joan Jan 1 '18 at 21:11
  • That pin 13 [GPIO 27] outputs 5V. – Alwin07 Jan 1 '18 at 21:12
  • None of the Pi's GPIO output 5V. Please edit your question and tell us what you are actually doing. – joan Jan 1 '18 at 21:18
  • Ok thanks I changed it, but I only want to turn on the pin. – Alwin07 Jan 1 '18 at 21:21
  • How do you know it doesn't work? What does gpio readall show. PS this pin is MISO – Milliways Jan 1 '18 at 22:52

When experiencing problems attempting to change GPIO the FIRST step in troubleshooting is to check what the Pi thinks the state of the pins are.

There are a number of ways of doing this gpio readall will show all pins, and you can check the state before and after.

The Pi uses (at least) 3 different methods on pin numbering gpio readall will show all.

In this case you appear to be attempting to use Physical pin numbers when gpio is expecting Wiring Pi numbering.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.